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Legal information 
Warning notice system 

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

DANGER  
indicates that death or severe personal injury will result if proper precautions are not taken. 

WARNING  
indicates that death or severe personal injury may result if proper precautions are not taken. 

CAUTION  
with a safety alert symbol, indicates that minor personal injury can result if proper precautions are not taken. 

CAUTION  
without a safety alert symbol, indicates that property damage can result if proper precautions are not taken. 

NOTICE  
indicates that an unintended result or situation can occur if the relevant information is not taken into account. 

If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. 
Qualified personnel are those who, based on their training and experience, are capable of identifying risks and 
avoiding potential hazards when working with these products/systems. 

Proper use of Siemens products 
Note the following: 

WARNING  
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended 
or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed. 

Trademarks 
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication 
may be trademarks whose use by third parties for their own purposes could violate the rights of the owner. 

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and software 
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the 
information in this publication is reviewed regularly and any necessary corrections are included in subsequent 
editions. 

 

 Siemens AG 
Industry Sector 
Postfach 48 48 
90026 NÜRNBERG 
GERMANY 

Order number: J31069-D0241-U001-A2-7618 
Ⓟ 11/2011 

Copyright © Siemens AG 2010, 
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Introduction  1
Purpose of this document 

These operating instructions contain information required for starting up and using the 
RF680M device. 

The documentation is aimed at commissioning engineers and machine operators who start 
up the application themselves, and it describes the functions of the software "RF-
MANAGER" and "RF680M". 

Scope of validity of this document 
This documentation is valid for the SIMATIC RF680M Mobile Reader and describes the 
delivery status from 12/2010. 

Further information   
The present instructions are a supplement to the operating instructions of the basic device 
PSION WORKABOUT PRO.  

The documents "Quick Reference Guide" and "Regulatory & Warranty Guide" for 
"WORKABOUT PRO C/M-E Hand-Held Computer" are included with the device. Please note 
the information they contain.  

You can find further information in the PSION User Manual and in the documentation for the 
docking station. 

Conventions   
The following terms/abbreviations are used synonymously in this document: 

● tag, transponder, mobile data memory (MDS), data carrier 

● Mobile reader, reader, handheld terminal, handheld; write/read device (SLG) 

History 
Previous editions of these operating instructions: 

 
Edition Note 
12/2010 First edition 
06/2011 Revision of the Operating Instructions 
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Safety Information  2
2.1 General safety instructions 

SIMATIC RFID products comply with the salient safety specifications to VDE/DIN, IEC, EN, 
UL and CSA. If you have questions about the validity of the installation in the planned 
environment, please contact your service representative. 

 

CAUTION  
Alterations to the devices are not permitted.  

Failure to observe this requirement shall constitute a revocation of the radio equipment 
approval, CE approval and manufacturer's warranty. 

 

Repairs 
Repairs may only be carried out by authorized qualified personnel. 

 

WARNING  
Unauthorized opening of and improper repairs to the device may result in substantial 
damage to equipment or risk of personal injury to the user. 
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Description  3
 

SIMATIC RF680M expands the RF600 identification system with a powerful mobile reader 
for applications in the areas of logistics, production and service. In addition, it is an 
indispensable aid for startup and testing. 

3.1 Field of application and features 

Device variants for different frequency ranges 
The SIMATIC RF680M device is available in two variants: 

● For the European frequency bands 

● For the US frequency bands 

Implementation environment, field of application and features  
● Field of application 

The SIMATIC RF680M mobile readers can be used in a harsh environment. The device 
is extremely rugged and protected against spray water. The backlit display is easy to read 
even under unfavorable lighting conditions. 

● RFID system 

The SIMATIC RF680M mobile reader is intended especially for the SIMATIC RF600 RFID 
system. The device can be used to process all RF600 tags and compatible transponders. 

● RF-MANAGER 

The SIMATIC RF680M mobile reader can exchange data with the RF-MANAGER over a 
WLAN connection. This means that RFID data that has been read locally is also available 
for evaluation in enterprise systems.  

● Tag standards 

It is not possible to edit data memories of other RFID systems.  The following tag 
standards are supported:  

– ISO 18000-6c (EPC Class1 GEN2) 

● The software "RF-MANAGER" and "RF680M" 

The RF-MANAGER and RF680M software is stored in non-volatile memory on an 
integrated flash disk and permits user-friendly, distributed reading and writing of all 
RF600 tags. 
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● API software interface 

The SIMATIC RF680M mobile reader is supplied with an API software interface that can 
be used by customized user programs. 

● Additional functional units for the SIMATIC RF680M Mobile Reader 

All other functional units of SIMATIC RF680M, such as barcode scanners and WLAN can 
be accessed via the interfaces supplied by the PSION device manufacturer. The 
descriptions and development tools can be obtained from the PSION websites. 

You can perform the following functions with the SIMATIC RF680M mobile reader: 

Functions  
● Reading the tag ID 

● Reading the data from the tag (data memory) 

● Writing the data to the tag 

● Reading and displaying the ID number of the tag (Tag/Scan) 

● Transferring the data that has been read to RF-MANAGER 

● Writing the tag ID to a transponder 

● Displaying reader status 

● Representing and editing the data in hexadecimal, ASCII and binary format 

● Activatable/deactivatable password protection for all write functions and for terminating 
the program 

● Menu prompting in English and German (switchable) 

● Saving of the read-in RF600 data to files in the mobile reader. The reader has 
approximately 900 MB available for this purpose. 

● Easy creation of your own RFID applications with the Software Application Interface (API) 

The RFID read/write unit of RF600 is integrated into the PSION basic unit. 

Security: Password protection  
You can assign different passwords for the SIMATIC RF680M mobile reader: 

● Password for the operating system. For more information, see Changing the password for 
the operating system (Page 21) 

● Password for the SIMATIC RF680M application. For more information, see Password for 
the SIMATIC RF680M application (Page 78) 

● Passwords for locking tag data areas. For more information, see Locking data areas 
(Page 71) 
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Accessories  
The charging and docking station (including wide-range power supply unit, 100 to 240 V AC, 
50 to 60 Hz) for recharging the battery and connecting to PCs via USB port must be ordered 
separately. This station has a charging bay for an additional replacement battery. See 
Ordering data (Page 99). 

3.2 Design 
 
Design of the SIMATIC RF680M  Item Description 

① Integrated read/write head 

② Holder for input pen 

③ Charge indicator  

④ USB connector 

⑤ Power supply 

⑥ Charging station 

⑦ On/off button 

⑧ ASCII keypad 

⑨ Numeric keys 

⑩ Microphone 

⑪ Display 

 

⑫ Loudspeaker 
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3.3 Antenna and antenna field 

Read head with integral antenna   
The antenna is housed in the read head ① under a cover. 

 
Figure  3-1 Read head with antenna 

Direction of propagation of the high-frequency field   
The write/read area for transponders is located on the end face as well as on the top and 
bottom of the front section of the enclosure.  

The antenna of the RF680M is linearly polarized. For successful reading and writing, the 
dipoles of the transponders and the antennas of the RF680M must be in parallel. Note the 
technical data of the individual transponders. 
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The following figure shows the positioning of transponders in front of the antenna. The 
maximum working range is achieved above and below the read head. 

 
Figure  3-2 Positioning of transponders 
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Power supply  4
4.1 Inserting the battery 

The mobile reader's battery is located on the rear of the unit.  

 
Steps for inserting the battery  
1. Turn the screws on the rear of the device in the direction of the arrow and lift the cover at the side 

where the screws are: 

 
2.  Hold the battery at an angle when inserting so that the side of the battery with the direction arrow 

is inserted into the battery compartment first (see the depiction of the arrow). 
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4.2 Charging the device 
Complete charging of an empty battery takes approximately 5 hours.  

Starting the charging operation 
The charging operation is started as soon as you insert the mobile reader into the charging 
station.  

 

WARNING  
Explosion hazard when using a different charging station. 

Use only the original charging station from PSION. Use of another charging station can 
result in explosions and serious personal injury. 

 

Detecting the level of charge  
You can check the level of charge via the charge indicator (LED) on the reader when the 
SIMATIC RF680M is placed in the charging station: 

Table  4- 1 Status LED 

LED color LED status Meaning 
Flashing Charging in progress. Battery charge is less than 80% 
Flashes slowly Charging in progress. Battery charge exceeds 80% 
Rapid flashing Battery temperature is higher than 45 °C. Charging not in 

progress. 

Green 

Permanently lit Battery is fully charged. 
red Permanently lit Charging not in progress. Battery fault! 

4.3 The backup battery 
The backup battery in the SIMATIC RF680M is used for retaining the application data when 
the main batteries are discharged. It is a rechargeable battery that is charged together with 
the main battery.  

Please note that a new backup battery (in the case of an empty or removed main battery) 
can only retain the data in the tag for a few minutes. It cannot be replaced because it is 
permanently connected to the device. 
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Commissioning  5
5.1 Scope of supply 

The scope of supply of the SIMATIC RF680M comprises the following components.   

● SIMATIC RF680M 

with integrated RFID read/write unit for RF600 

● Documentation  

in the directory "Flash Disk\SIMATIC RF680M\Documents\deutsch" or 
"Documents\english": 

– The SIMATIC RF680M Operating Instructions 

– The "Mobile Readers" function manual 

– The PSION WORKABOUT PRO 3 Operating Instructions 

● Drivers and software  

in the directory "Flash Disk\SIMATIC RF680M\Support" 

– The RFID software interface API 

– The USB driver (for procedure, see the chapter on data transmission between the PC 
and mobile reader for instructions on installing the driver Prerequisites (Page 88)) 

 
Figure  5-1 Directory "Flash Disk\SIMATIC RF680M" 

  Note 
Information on accessing the directory "Flash Disk"  

See Chapter Data transfer between the PC and mobile reader (Page 88) 
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5.2 Switching the device On and Off 

Requirements for startup 
● The mobile reader SIMATIC RF680M is mounted 

● The device battery is charged and inserted in the device (see chapters Charging the 
device (Page 18) and Inserting the battery (Page 17)). 

  Note 

Before switching the device on for the first time, you must insert the reader into the 
charging unit and charge it for approximately five hours. 

Switching the device on/off  
To switch the reader on or off, press and hold the ON/OFF button for at least one second. 

 

Figure  5-2 ON/OFF button 

After switching on, the first power-up lasts a few seconds. 

Automatic shutdown of the device  
The device shuts down automatically if no key is pressed for three minutes. After switching 
on again, the reader continues to operate with the same interface it was using before it was 
manually or automatically switched off. See chapter The automatic power-saving function 
(Page 93). 

5.3 Recommendations for first commissioning 
We recommend the following steps for first commissioning: 

1. Creating a back-up copy 

2. Changing the password for the operating system 

3. Implementing other operating system settings (e.g. WLAN) 

4. Performing a back-up 

The steps are explained in more detail in the following chapters.  

5.3.1 Creating a back-up copy 
Create a backup copy so that you can restore the delivery status of the device when 
necessary.   
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Requirement 
The reader is connected to the PC. 

Procedure 
Copy all the data from the directory "Flash Disk" to your PC. See also Chapter Data transfer 
between the PC and mobile reader (Page 88) 

 

NOTICE  
Do not delete files with the extension ".PFL"  

Files with the extension ".PFL" in the "Flash Disk" directory are used to restore the status 
that existed at the time of the last back-up and must therefore not be modified or deleted. If 
the files with the ending ".PFL" are damaged or lost, the original status of the device can 
only be restored at the factory. 

To restore a backup, replace all the data on the device with your backup copy and then run 
a system reset. 

 

5.3.2 Changing the password for the operating system 
Assign a password to protect the system from unauthorized access. 

Prerequisite 
The operating mode must be set to "Supervisor". See Chapter Operating modes (Page 22) 

Procedure for changing the password 
To change the password of the operating system, select "Start > Security". Enter the 
previous password. The password on delivery is "123456". 

You can assign a new password using the button "Set Password". 

5.3.3 Performing a back-up 
Set the operating mode to "Supervisor". See Chapter Operating modes (Page 22)   

Select "Start > Settings > Control Panel > Total Recall". 

1. Select the "Create Profile" button. 

2. Select "Auto Restore" and then confirm with the "-->" button. 

3. Select "Default Backup" and confirm this with the "Create Profile" button. 

Reaction: The backup is started. 

4. Click "Finished" to return to the application. 
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All changes, e.g. a new password for the operating system, are now stored in the back-up 
secure against power failure. 

See also 
System reset (Page 93) 

5.4 Basic settings in the operating system 

5.4.1 Operating modes 

Operating modes 
The SIMATIC RF680M device has two operating modes: 

1. "Supervisor Mode" 
Configuration and settings for the SIMATIC RF680M Mobile Reader. 

2. "User Mode" 
Default mode. The user can only use the installed service and 
 test applications. The start menu functionality is restricted. 

Changing the operating mode  
You can change the operating mode in the "Security Level" settings. "Start > Security" is 
used for changeover:  

 
Figure  5-3 Operating mode 

Changeover to "Supervisor Mode" is password-protected. On delivery, this password is set 
to "123456" and should be changed the first time it is used for security reasons. 

See also 
System reset (Page 93) 
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5.4.2 Adjusting the acoustic signal volume 
The tag functions trigger an acoustic signal indicating whether the operations were 
successful or were terminated with an error. You can switch these acoustic 
acknowledgements/signals on and off and you can regulate their volume.  

Adjusting the volume of the acoustic signals  
Press the blue labeled <FN> button in each case to regulate the volume of the acoustic 
signals in steps using the "Plus" button (louder) or the "Minus" button (quieter). 

 
Figure  5-4 Keys for regulating the volume 

Specific setting of the acoustic signals 
In "Supervisor" mode, select "Start > Settings > Control Panel > Volume & Sounds". 

On the "Volume" tab, you can regulate the volume between "Soft" and "Loud" using the bar. 

You can also permit or deactivate acoustic signals for different messages by activating the 
relevant checkboxes. 

5.4.3 Set the backlighting of the screen 
To alter the brightness of the display, select "Start > Settings > Control Panel > Display > 
Backlight in "Supervisor" mode.  
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Operation  6
6.1 The keypad 

6.1.1 Key functions 

Table  6- 1 Key functions   

Overview of the keypad Item Key label Function 

① <F2> If you first press the blue <FN> 
key, the function of other keys 
is changed. Similar to the 
<ALT> key in the Windows 
operating system. 

② 

③ 

 
<SCAN> 
 

 
Scanning of tags 

④ Blue <FN> Shift key: 
Changes the function of other 
keys to that shown by the blue 
labeling 

⑤ <TAB> Moves the cursor to the right or 
down at specific intervals. 

⑥ <ENTER> On/Off key, Enter key 

⑦ <SPACE> Inserting spaces.  
In a Windows dialog window, 
checkboxes can be activated or 
deactivated with the <SPACE> 
key. 

⑧ <SHIFT> Display of uppercase letters (A-
Z) and symbols also specified 
on the numeric keys (e.g. &, 
*,...). 

⑨ <BKSP> Moves the cursor to the left to 
delete the last entered 
character. If the blue <FN> key 
is pressed first, the character 
after the cursor is removed. 

 

⑩ <ESC> Closes the currently open 
menu, dialog window or started 
application and returns you to 
the previous interface. 
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Overview of the keypad Item Key label Function 

⑪ Orange <FN> Shift key: 
Changes the function of other 
keys to that shown by the 
orange labeling 

⑫ Arrow keys Enable navigation to the left, 
right, up and down in the 
display. 

⑬ <F1> If you first press the blue <FN> 
key, the function of other keys 
is changed. Corresponds to the 
<CTRL> key in the Windows 
operating system. 

6.1.2 The shift keys 
An activated shift key causes a change in the function of the subsequently pressed keys. 

The following keys of the SIMATIC RF680M are shift keys: 

● <SHIFT> 

● Orange <FN>  
(changes the key assignment in accordance with the orange-colored labeling on the 
keypad) 

● Blue <FN>  
(changes the key assignment in accordance with the blue-colored labeling on the keypad) 

Activating the shift keys: 
When you press a shift key once briefly, it is activated and the name of the selected switch 
key appears in lowercase in the task bar, e.g. "Org key", "Blue key". 

Any subsequently pressed key then changes its function, the display in the task bar 
disappears and the shift key is deactivated again. 

If you press a shift key briefly twice in succession, it will become inactive again.  

6.2 The Touch display 
The screen of the SIMATIC RF680M is designed as a touch-sensitive display. You can 
easily enter commands by touching it with the pen.  
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Software overview  7
7.1 Software applications 

Two software applications are available to you in SIMATIC RF680M:  

● The software "RF680M" of the standalone product SIMATIC RF680M 

The application program "RF680M" is primarily intended for use in the service and test 
fields for reading and writing tags in RFID applications. 

● The software "RF-MANAGER"  

With the application software "RF-MANAGER", the SIMATIC RF680M device becomes 
an integral component of that of SIMATIC RF-MANAGER. 

Data acquisition for the "RF-MANAGER" software is configured in the engineering system 
of SIMATIC RF-MANAGER.  

The software serves to acquire data and transfer it to SIMATIC RF-MANAGER. 

7.2 Overview of possible applications 
You can use the SIMATIC RF680M device in different ways: 

As a standalone product or in combination with SIMATIC RF-MANAGER. 

 
Interfacing to SIMATIC RF-MANAGER with the software "RF-MANAGER" 

Application mode "Remote" Application mode "Mobile" 

Standalone product with 
the software "RF680M 

• RF680M behaves like a stationary reader 
• The acquired data are only displayed and 

transferred to RF-MANAGER 
• The acquired data cannot be modified 

• The acquired data is acknowledged 
before being transferred to RF-
MANAGER. Data that has been 
incorrectly scanned can be deleted. 

• All the tag data from the RFID chip can 
also be displayed or edited depending 
on the configuration in the engineering 
system. 

• Acquisition of tag data 
• All editing functions are 

permitted. 
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The software "RF-MANAGER"  8
8.1 Prerequisites for working with the software "RF-MANAGER" 

8.1.1 Necessary components 

WLAN module 
Communication with the runtime system of RF-MANAGER is performed over a radio link. 
The SIMATIC RF WLAN module is required for this purpose.  

Barcode scanner 
When reading of bar codes is configured in the engineering system of RF-MANAGER, you 
will need the accessory SIMATIC RF barcode scanner for the SIMATIC RF680M device.  

Both components can be ordered and installed separately as accessories. [See Ordering 
data (Page 99) ]. 

8.1.2 Starting the software "RF-MANAGER" 
To start the RF-MANAGER application, double-click the "RF-MANAGER" icon on the 
desktop.  

A connection to RF-MANAGER will only be established when the "RF-MANAGER" software 
has been started and the WLAN connection is active. 

After it has been correctly installed, the SIMATIC RF680M Mobile Reader automatically 
receives its configuration from RF-MANAGER. 
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8.1.3 Preconditions for parameterization of the WLAN connection 
● The mobile reader must be ready for operation (the battery is charged). 

● The mobile reader must contain a WLAN card. 

● A WLAN connection must exist between the reader and the network of the PC, e.g. via an 
access point. 

● Information regarding the WLAN settings must be available. 

● The operating mode of the mobile reader must be set to "Supervisor". 

 

8.1.4 Settings in the Engineering System 
1. Enter IP address of the reader 

Enter the assigned IP address in the device settings of the mobile reader ("RFID devices 
> RFID device_X"). 

2. Enter the network address of the PC 

Enter the network address of the PC in the network settings ("Device settings > RFID / 
network settings"). 
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 Note 
An automatic reader search is not possible in the Engineering System 

The automatic reader search via "Project > Reader configuration > Communication settings" 
does not function in the case of mobile readers. 

 

8.1.5 Parameterizing the WLAN card in the SIMATIC RF680M mobile reader 
Two examples are given below for the procedure that you can follow for configuring the 
WLAN card of SIMATIC RF680M. 

Consult your network administrator to ensure that the WLAN connection is set up correctly. 
You will find detailed information on configuring the WLAN in the operating instructions for 
the PSION WORKABOUT PRO.  

Example 1 
With this procedure, the active radio networks are displayed automatically.  

1. Set the operating mode to "Supervisor" in SIMATIC RF680M. 

2. In SIMATIC RF680M, select "Start > Programs > Summit > SCU" 

3. Under "Active Config", select "Third party". 

4. To activate these changes, change to the device to the "Powerdown" mode by pressing 
the blue <FN> key and the on/off button at the same time for approximately 7 seconds. 
The device then restarts. 

5. Select the required active wireless network in the dialog that now opens. 

6. Click the "Connect" button and enter the respective encryption code under 
"Authentication" and "Network key". 

7. Click on the "OK" button. 

Example 2 
1. Select "Start > Programs > Summit > SCU" in the mobile reader. 

2. Click on the "Profiles" tab. 

3. Select the "New" button to create a new profile setting 

4. Enter a name for the profile setting. 

5. At least make the following settings: 

– SSID (name of the radio network), e.g. "RF680M" 

– Auth Type (security level): e.g. "Shared" 

6. Select the encryption required under "Encryption": e.g. "WPA2 PSK". 



The software "RF-MANAGER"  
 8.1 Prerequisites for working with the software "RF-MANAGER" 

 SIMATIC RF680M Mobile Reader 
32 Operating Instructions, 06/2011, J31069-D0241-U001-A2-7618 

7. Then click the button "WEP keys/PSKs". Enter the encryption code and confirm with 
"OK". 

8. Click the "Commit" button to confirm the settings. 

9. In the "Main" tab, under "Active config", select the profile that should be active. 

10. To activate these changes, change to the device to the "Powerdown" mode by pressing 
the blue <FN> key and the on/off button at the same time for approximately 7 seconds. 
The device then restarts. 

  Note 
Other encryption possibilities 

You can also use other encryption methods, depending on the access point. "WEP" 
encryption is no longer regarded as secure; you should not use this. 

 

8.1.6 Enter the IP address in the mobile reader 
If a DHCP server is not present in the network, you must enter the IP address of 
SIMATIC RF680M in the SIMATIC RF680M mobile reader:  

1. Double-click the WLAN icon in the taskbar for this purpose. 

2. In the "IP Information" tab, click the "Configure" button and select "Specify an IP 
address". Enter the IP address. 

As an alternative, you can also enter the IP address as follows:  

1. "Start > Settings > Control Panel > Network and Dial-up Connections" and select the 
relevant connection. 

2. In the "IP Information" tab, click the "Configure" button and select "Specify an IP 
address". Enter the IP address. 

8.1.7 Creating a back-up 
Create a back-up to save the settings even in the case of power failure. The steps you have 
to perform to do this are described in detail in the section Performing a back-up. 

See also 
Performing a back-up (Page 21) 
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8.2 Application mode "Remote" 
In application mode "Remote" that is configured via the Engineering System in 
RF-MANAGER, the SIMATIC RF680M mobile reader has the properties of a stationary 
reader. This means that the acquired data are only displayed on the reader and transferred 
to RF-MANAGER.  

You are not able to acknowledge or reject the acquired data in SIMATIC RF680M. 

8.2.1 Acquire data and transfer it to RF-MANAGER 

Data acquisition 
Depending on the configuration in the Engineering System, you can activate a barcode or 
RFID read using the hardware keys or the "Scan" button of SIMATIC RF680M.  

If you have configured the reading of barcodes, the acquired barcode will be preceded by 
"BAR". 

If you have configured the reading of RFID tag data, the acquired tag ID will be preceded by 
"RFID". 

 
Figure  8-1 List of RFID tag IDs. 

Transfer data to RF-MANAGER 
All acquired data is transferred immediately to RF-MANAGER. 
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8.3 Application mode "Mobile" 
In application mode "Mobile" that is configured via the Engineering System in 
RF-MANAGER, you can check the read data for validity in the SIMATIC RF680M mobile 
reader and reject any faulty reads. Only that data which you have acknowledged will be 
transferred to RF-MANAGER.  

Functional expansion by means of configuration in the Engineering System  
When the function "Edit Tag" is activated in RF-MANAGER, you can display and edit all the 
data for the read RFID tag.  

8.3.1 Acquire data and transfer it to RF-MANAGER 

Data acquisition 
Depending on the configuration in the Engineering System, you can activate a barcode or 
RFID read using the hardware keys, the RF-MANAGER or the "Scan" button of SIMATIC 
RF680M.  

If you have configured the reading of barcodes, the acquired barcode will be preceded by 
"BAR". 

If you have configured the reading of RFID tag data, the acquired tag ID will be preceded by 
"RFID". 

 
Figure  8-2 List of RFID tag IDs. 

Transfer data to RF-MANAGER 
If you want to transfer data to RF-MANAGER, select the "OK" button.  

The data then disappears from the user interface of the SIMATIC RF680M. 
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Read Data 
You can edit the data scanned from an RFID tag via the "Data" button.  

The following chapters contain detailed information about this. 

Delete data 
You can reject any data that has been incorrectly acquired via the "Delete" button. 

8.3.2 The data editor 

Prerequisites for working in the data editor 
In order to process tag data, a tag must have been scanned by the SIMATIC RF680M device 
and its tag ID must be indicated in the display. See Chapter Acquire data and transfer it to 
RF-MANAGER  (Page 34). 

The transponder data can be edited in the editor window in hex, ASCII or decimal format. 
You can toggle between the two in the "Tools > Settings" menu. (See Settings (Page 54)). 
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Interface structure of the data editor  
 
User interface Item Description 

① Menu bar 

② Indication of the tag ID 

③ Drop-down list box with the transponder-specific memory 
areas (e.g. EPC, TID, USER) that are displayed in the data 
field. 

④ Length of the data area (the field can be edited when 
"Total" is not checked) 

⑤ Data field 
The data can be displayed in either hexadecimal, decimal 
or ASCII format.  

⑥ Buttons for processing the tag data: 
• Scan tag (ID) 
• Read tag data 
• Write to the tag 

⑦ Indication of the tag type 

⑧ The editor window contains the tag data. The size of the 
represented data depends on the tag type. 

⑨  (Start) address (the field can be edited when "Total" is not 
checked) 

⑩ "Complete" check mark: Indication of the completely 
selected memory area; all memory areas of the tag are 
always read or written at once, independent of the memory 
area currently set. 

 
 
 

⑪ Length of the user area: 
The software "RF-MANAGER" contains an additional field 
for the length of the user area. In this field, you must enter 
the tag-specific length of the user area. 

 

One memory area of the most recently scanned tag is always shown in the editor. In the 
drop-down list box [③], you can select and display the different memory areas of the tag. If 
you check "Complete" ⑩, the current memory area will be displayed complete in the editor, 
otherwise you can enter values under "Address" [⑨] and "Length" [⑩] to display the 
relevant data area only.  
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The "current area" 
 
Current area  Description 

 
 

When "Total" is not checked, the area is displayed that is specified 
in the fields "Address" and "Length". 
You can reach the individual addresses using the input pen. If you 
change the values, they will have a green background. The green 
background remains until the data are transferred/written to the 
transponder. The color green therefore indicates that the actual tag 
data differs from the values visible in the editor. 
All other data areas of the tag are shown against a white 
background.  

Memory area ISO 18000-6C (EPC Class1 Gen2) 
● USER: 

User data area. Freely available  
its size or presence is specific to the manufacturer. 

● EPC: 
Memory area in which the tag ID is stored. 
The area is read-only. 

 

① PC: 2 bytes of Protocol Control bits 

② EPC: 12 bytes tag ID (in this example: 
30112233445566778899AAC0) 

 
 

③ CRC: 2 bytes of check sums 
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● TID: 
Memory area for tag ID (tag identifier) 
The area is read-only. 

● Reserved: 
Memory area for access password and kill password 
The area may be read only (manufacturer-specific). 

 

① Kill password 

 

② Access password 

For further information on the detailed structure of the different areas, see "EPCglobal-
Specification for RFID Interface" (EPCTM Radio-Frequency Identity Protocols Class-1 
Generation-2 UHF RFID Protocol for Communications at 860 MHz - 960 MHz, Version 1.0.9) 

See also 
Acquire data and transfer it to RF-MANAGER  (Page 33) 
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8.3.2.1 Progress and timeout display 
The tag functions carry out communication with the transponder. They indicate the progress 
of the currently executing function and any timeout, if applicable: 

Progress display in the case of the tag function 
During data transfer, the progress of the executing function is displayed in the form of a bar 
display:  

 
Figure  8-3 Progress display 

The tag function is not interrupted if you briefly move the tag out of the read field.  

Timeout display in the case of the tag function 
If the tag remains unedited for longer than 20 seconds, the function is interrupted and a 
message window appears: 

 
Figure  8-4 Timeout display 

You can now stop the command completely with "Yes" or continue it with "No". If you 
continue, the interrupted command is continued at the point of interruption. 
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8.3.2.2 Read tag 
 

 Note 
Distance limits between the tag and the reader 

Please observe the maximum distance limits between the reader and the tag when reading a 
tag. These depend on the:  
• Tag type 
• Ambient conditions / fixing method of the tag. 

Under favorable conditions, the limit distances are 250 cm. 
For additional information, see Technical data (Page 97). 

 

Read tag data  
If you click the "Read" button in the data editor (or press <Ctrl+R>), you can read the data 
from the tag. The read-in data appears in the editor. 

 
"Read" button 

Reading the data area of a tag  
In the data editor, you can use the drop-down list box to select the required memory area of 
the tag whose data you want to read, and reduce it, if required, by removing the check mark 
from "Complete" and entering the address and length in the respective fields.  

Read complete tag 
If all memory areas of the tag are to be completely read or written together, set the check 
mark for "Complete".  

With this function you can display the complete size of the selected memory area. 

If the check mark is set for "Complete", "Read all" and "Write all" are displayed on the 
buttons. 



 The software "RF-MANAGER" 
  8.3 Application mode "Mobile" 

SIMATIC RF680M Mobile Reader 
Operating Instructions, 06/2011, J31069-D0241-U001-A2-7618 41 

 
Figure  8-5 "Read All" button 

 

 Note 
ID check 

It is checked for all tags before any read or write procedure whether the tag ID displayed in 
the editor corresponds to the ID of the tag that is located in the field of the SIMATIC 
RF680M. If this is not the case, time-out will be displayed after 20 seconds. 

 

See also 
Settings (Page 80) 

8.3.2.3 Writing to the tag 

Write tag data  
If you click the "Write" button in the data editor (or press <Ctrl+W>), you can write the data 
that is currently displayed in the editor to the tag.  

 
"Write" button 

Writing the data area of a tag 
In the data editor, you can select the required memory area of the tag in which you want to 
write data, and reduce it, if required, by removing the check mark from "Complete" and 
entering the address and length in the respective fields.  
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Writing the complete tag 
If all memory areas of the tag are to be completely read or written together, set the check 
mark for "Complete".  

With this function you can display the complete size of the selected memory area. 

If the check mark is set for "Complete", "Read all" and "Write all" are displayed on the 
buttons. 

 
Figure  8-6 "Write All" button 

 

 Note 
ID check  

It is checked for all tags before any read or write procedure whether the tag ID displayed in 
the editor corresponds to the ID of the tag that is located in the field of the SIMATIC 
RF680M. If this is not the case, time-out will be displayed after 20 seconds.  

 

 

See also 
Settings (Page 80) 

8.3.3 Overview of functions 
When the RF-MANAGER application starts up, the screen for scanning tags appears on the 
display. You can then scan tags or call a function from the menu. You can find out from the 
following table which functions are available in the respective application mode.  

 

 Note 

If you want to use the function "Edit Tag" in application mode "Mobile", you must activate this 
in RF-MANAGER. 
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 Application mode  
Function Remote Mobile Edit Tag Description 

Open - - X Load file from the integral PSION "Flash Disk" 
directory to the work memory. 

Save Tag - - X Save read-in tag data to the "Flash Disk" directory. 
Save Tag As - - X Save read-in tag data to the "Flash Disk" directory. 

File 

Exit X X X Exit application 
Scan - - X Read tag ID 
Write ID - - X Write the tag ID to a tag 
Read Data 
- Read <CTRL+R> 
- Write <CTRL+W> 

- - X Read tag data, write tag 

Tag 

Functions - - X Lock data areas on the tag 
Password X X X Change password for the application 
Reader status X X X Information about the reader 

Tools 

Language X X X Set the menu language 
 Settings - - X Define tag area for reading/writing 

Specify format (editor, data, address, length) 
Help Info X X X Manufacturer data 
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8.3.4 The functions in the "File" menu 

8.3.4.1 Overview of file functions 
The following file functions are available that you can select in the menu via "File":  

● Open (with "Edit Tag" function) 

● Save Tag (with "Edit Tag" function) 

● Save Tag As (with "Edit Tag" function) 

● Exit 

 
Figure  8-7 The file functions 

8.3.4.2 Open 
The function is available in the application mode "Mobile" when "Edit Tag" has been 
activated in RF-MANAGER. 

You can load a file via "File > Open" if the file was saved beforehand with the command "File 
> Save" or if it was transferred from the PC to the "Flash Disk" directory of the SIMATIC 
RF680M (also see Data transfer between the PC and mobile reader (Page 88)).  

All the files of the "Flash Disk" folder are displayed. You can select the desired file via the 
touchscreen or by entering the filename under "Name" and <OK>. 



 The software "RF-MANAGER" 
  8.3 Application mode "Mobile" 

SIMATIC RF680M Mobile Reader 
Operating Instructions, 06/2011, J31069-D0241-U001-A2-7618 45 

8.3.4.3 Save Tag / Save Tag As 
The functions are available in the application mode "Mobile" when "Edit Tag" has been 
activated in RF-MANAGER. 

Via "File > Save", you can save data currently displayed in the editor of the reader to a file on 
the SIMATIC RF680M. If you select "Save", the current file will be replaced; if you select 
"Save Tag As", you can select a new directory or a new file name.  

The filename can be up to 100 (alphanumeric) characters in length. XML format is used 
automatically for saving. Also refer to the Chapter "File storage on the RF680M (Page 87)" 
as well as "Organization of the .XML files in the Flash Disk directory (Page 90)". 

8.3.4.4 Exit 
You can exit the RF-MANAGER program using "File > Exit" or the <ESC> key. You then 
reach the WinCE operating system level of the PSION Workabout Pro. You require the 
password relevant to the application for this, if you have previously assigned one.  

 

 Note 

A connection to RF-MANAGER is established as long as the "RF-MANAGER" software is 
running on the SIMATIC RF680M. On exiting, this connection is closed down. 
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8.3.5 The functions in the "Tag" menu 

8.3.5.1 Overview of tag functions 
The following tag functions are available that you can select in the menu via "Tag":  

● Scan (with "Edit Tag" function activated) 

You can switch to data acquisition by selecting this function (seeAcquire data and 
transfer it to RF-MANAGER  (Page 34)). 

● Read Data (with "Edit Tag" function activated) 

You can switch to the data editor by selecting this function (seeThe data editor 
(Page 35)). 

● Write ID (with the "Edit Tag" function activated) 

● Lock Tag (with the "Edit Tag" function activated) 

● Kill Tag (with the "Edit Tag" function activated) 

 
Figure  8-8 RF-Manager tag functions 
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8.3.5.2 Write ID 
You can change the ID of a tag using the function "Write ID".  

Select "Tag > Write ID" for this purpose. The following window is displayed.  

 
Figure  8-9 "Write ID" window 

Enter ID 
Enter the desired ID.  

It must be possible to divide number of ID characters by four. 

Transferring the ID to the transponder 
Click the "OK" button to transfer the ID to the tag. 

"Access Password" field 
When the tag to be written is protected with an access password, you must enter the 
password in the "Access Password" field. 

 

 Note 
Only keep one tag in the scanning range of the SIMATIC RF680M 

Ensure that only one tag is in the scanning range of the SIMATIC RF680M when the tag ID 
is being written. Otherwise, the tag will not be written. 
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8.3.5.3 Locking data areas 
You can lock a tag by means of the "Lock Tag" function.  

Select "Tag > Lock Tag..." for this purpose. The following window is displayed. 

 
Figure  8-10 Lock Tag 

In the "Mask" line, you can select the following transponder-specific memory areas: 

● "Kill": Kill Password 

● "Acc": Access Password For memory areas EPC, TID and user memory 

● "EPC": EPC memory 

● "TID": TID memory 

● "Usr": User memory 

"Lock" 
The entries under "Mask" determine which function is executed in the action area.  

 
0 The action will not be executed 
1 The action will be executed 

 

 
Line Kill PWD Access PWD EPC memory TID memory User memory 
Mask 0/1 0/1 0/1 0/1 0/1 0/1 0/1 0/1 0/1 0/1 
Action r/w p r/w p w p w p w p 

The entry in the "Action" line specifies how the associated memory area will be locked. 
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● The identifier "r/w" defines password protection for reading/writing 

● The identifier "w" defines password protection for writing (reading is permitted) 

● The identifier "p" specifies permanent locking 

All the possible combinations of "r/w", "w" and "p" are listed in the table below complete with 
their significance for the different memory areas. 

The tag has the status "Open" when it has been identified (access without password) and 
"Secured" when its access password has been evaluated. 

 
w p Description 
0 0 The associated memory area can be written in both the "Open" and "Secured" states.  
0 1 The associated memory area can be permanently written in both the "Open" and "Secured" 

states and can no longer be locked.  
1 0 The associated memory area can only be written in the "Secured" state, but not in the 

"Open" state.  
1 1 The associated memory area cannot be written, regardless of the state of the tag. 

 

 
r/w p Description 
0 0 The associated password area can be read and written in both the "Open" and "Secured" 

states.  
0 1 The associated password area can be permanently read and written in both the "Open" 

and "Secured" states and can no longer be locked.  
1 0 The associated password area can be read and written in the "Secured" state, but not in 

the "Open" state.  
1 1 The associated memory area cannot be read or written, regardless of the state of the tag.  

This state can be used to protect the passwords on the tag from being read out and 
overwritten. 

Example 
 
 Kill PWD Access PWD EPC memory TID memory User memory 
Mask 1          1 1          1 1          1 0          0 0          0 
Action 1          0 1          0 1          0 0          0 0          0 

In the above example, the mask bits only enable the actions for the memory areas "Kill 
password", "Access password" and "EPC memory"; no change is made to the access 
mechanisms in the TID memory and user memory areas. 

The bits assigned to the mask in this example mean: 
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● "Kill password":  
The kill password can be read and written by the "Secured" state, but not by the "Open" 
state.  
You must know the access password of the tag to read or write the kill password. 

● "Access password":  
The access password can be read and written from the "Secured" state, but not from the 
"Open" state.  
You must know the access password of the tag to read or write the access password. 

● "EPC memory": 
This memory area can be written from the "Secured" state, but not from the "Open" state.  
You must know the access password of the tag to write a new ID to the tag. 

For detailed information, please refer to"EPCglobal-Specification for RFID Interface" 
(EPCTM Radio-Frequency Identity Protocols Class-1 Generation-2 UHF RFID Protocol for 
Communications at 860 MHz - 960 MHz, Version 1.0.9) 

Displaying and executing the "Lock Tag..." function 
The current status of the action bit of a tag cannot be scanned. If the specified function 
cannot be executed, an error message will not be output directly from the tag. In this case, 
the command will only be terminated after 20 seconds with the time-out. In this case, check 
the passwords that you have entered and the bits in the mask and action lines carefully 
before you activate the command again. If the status of the available tag is not known to you, 
it is highly probable that this command will always result in a time-out. 

8.3.5.4 Kill tag 
You can erase a tag by means of the "Kill Tag..." function.  

The prerequisites for this are: 

● The tag must have a valid kill password (non-zero) 

● The password is entered in the interface in the "Kill Password" field. 

Select "Tag > Kill Tag..." for this purpose.  
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The following window is displayed. 

 
Figure  8-11 Kill tag 

8.3.6 The functions in the "Extras" menu 

8.3.6.1 Overview of the Extras functions 
The Tools menu contains the following functions that you can select via "Tools":  

● Password (application password) 

● Reader status 

● Language 

● Settings (with "Edit Tag" function activated) 

 
Figure  8-12 The Tools functions 
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8.3.6.2 Password for the RF-MANAGER application. 
As an option, you can assign a password for the RF-MANAGER application.  

Select "Tools > Password" from the menu.  

 
Figure  8-13 Password 

1. Enter a password with up to 8 characters under "New Password". 

2. Then enter the password again under "Confirm password". 

3. Select the "OK" button. 

The password is now set. All write functions to a tag are now protected by this password. 

If you want to perform a write function now, you must enter the appropriate password. You 
only have to enter the password once in the case of several consecutive write commands. It 
will remain valid for 5 minutes after the last write function is executed. 

This password is also required to exit the application.  

Default password 
No password is assigned in the delivery condition. 

 

 Note 
Forgot password? 

If you have forgotten your password, the original status of the device can be restored. See 
System reset (Page 93) 

 



 The software "RF-MANAGER" 
  8.3 Application mode "Mobile" 

SIMATIC RF680M Mobile Reader 
Operating Instructions, 06/2011, J31069-D0241-U001-A2-7618 53 

8.3.6.3 Reader status 
Version statuses and settings of the RF600 read/write device can be read out with the 
"Reader Status" function. 

● API version 

● Model (US or EU) 

● Firmware version of the RFID module. 

 
Figure  8-14 Reader status 

8.3.6.4 Setting the language 
You can set the following menu languages for operating the application : 

● English 

● German 
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Procedure for selecting the language 
Select the desired language in the "Language selection" window of the "Tools > Language" 
menu and confirm with "OK". 

 
Figure  8-15 Language selection window 

8.3.6.5 Settings 
You can make the following settings using this function  

● Specifying the write and read area of a tag 

● Setting data formats 

Select "Tools > Settings" to parameterize these settings. The "Settings" window opens: 

 
Figure  8-16 Settings window 
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Settings under "Format" 
You can set different formats (for the editor, data, address and length) under "Format" that 
are explained below. 

● Effect of the "Editor" settings:  
Byte, binary  
Depending on the format that you select, the interface in the data editor is as depicted 
below: 

 
Presentation in the data editor for the settings 

"Byte" "Binary" 

 
 

 
 

Presentation in bytes Presentation with "0" and "1" 

● Effect of the "Data" settings:  
Hexadecimal, decimal or ASCII number format 
"Hex" or "Dec" presentation format can be recognized in the "Address" and "Length" lines 
in the data editor. 
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Hex Dec ASCII 

 
 

 
 

 
 

 

● Effect of the settings under "Address" and "Length" 
When the check mark is missing, you can enter decimal data here. If you subsequently 
set the check mark, the data will be converted into hexadecimal format. Depending on the 
format setting, the values will be changed in the editor. 
You can see from the data editor whether "Hex" or "Dec" is activated; for Hex format, "0x" 
is shown for "Address" and "Length": 

 
 "Hex" check mark not activated "Hex" check mark activated 
Display in the 
editor   

Settings under "Auto-Save Filename" 
Under "Auto-Save Filename" you can define whether the same file with the same name is 
always updated when scanning tags, or whether new files are saved in each case.  

 
Figure  8-17 Auto-Save Filename 
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● "READ.XML" 

If the setting "READ.XML" is selected, the same file READ.XML is always updated each 
time tag data is read.  

● "Tag_xxx.XML" 

If the setting "Tag_xxx.XML" is selected, a new file with the name TAGxxx.XML is created 
each time tag data is read. "xxx" is replaced by the ID of the read tag.  

If a tag with the same ID is read again, the corresponding file is overwritten. 

"READ.XML" is set as the default value. 

8.3.7 The functions in the "Help" menu 

8.3.7.1 Overview of "Help" menu 
The "Help" menu contains the following function that you can select via "Help":  

"About": 

 
Figure  8-18 "Help" menu 

Using "Help > About" you can obtain information on the following points:  

● Information about the device: EU or US version 

● Software version 

● Manufacturer of the application Siemens AG 
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"RF680M" software  9
9.1 Overview of functions 

When the SIMATIC RF680M application starts up, the screen for scanning tags appears on 
the display. You can then scan tags or call a function from the menu.  

 
Function Shortcut  Description 

Open - Load file from the integral PSION "Flash Disk" directory to 
the work memory. 

Save Tag - Save read-in tag data to the "Flash Disk" directory. 
Save Tag As - Save read-in tag data to the "Flash Disk" directory. 
Save List As - Save list of scanned tag IDs. 
Append List - Append list of scanned tag IDs from a directory. 

File 

Exit - Exit application 
Scan <CTRL+S> Read tag ID 
Write ID - Write the tag ID to a tag 
Read Data 
- Read 
- Write 
- Copy 

 
<CTRL+R> 
<CTRL+W> 

Read tag data, write tag, copy tag data 

Lock Tag  - Lock data areas on the tag 

Tag 

Kill Tag - Kill tag 
Password - Change password for the application 
Tag Type - Set tag type 
Reader status - Information about the reader 
Reader settings  - Setting of the antenna performance and the tag protocol 
Language - Set the menu language 

Tools 

Settings - Set tag scanning mode (individually or bulk) 
Define tag area for reading/writing 
Specify format (editor, data, address, length) 

Help Info - Manufacturer data 

9.2 Start "RF680M" software 
To start the RF680M application, click the "RF680M" icon on the desktop.  
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9.3 The data editor 

Prerequisites for working in the data editor 
In order to process tag data, a tag must have been scanned by the SIMATIC RF680M device 
and its tag ID must be indicated in the display. See Chapter Scanning RFID tags and their 
tag ID (Page 65).  

The transponder data can be edited in the editor window in hex, ASCII or decimal format. 
You can toggle between the two in the "Tools > Settings" menu. (See Settings (Page 80)). 

Interface structure of the data editor  
 
User interface Item Description 

① Menu bar 

② Indication of the tag ID 

③ Drop-down list box with the transponder-specific memory 
areas (e.g. EPC, TID, USER) that are displayed in the data 
field. 

④ Length of the data area (the field can be edited if 
"Complete" is not checked) 

⑤ Data field 
The data can be displayed in either Hex, decimal or ASCII 
format.  

⑥ Buttons for processing the tag data: 
• Scan tag (ID) 
• Read tag data 
• Write to the tag 
• Copy data to another tag 

⑦ Indication of the tag type 

⑧ The editor window contains the tag data. The size of the 
represented data depends on the tag type. 

⑨  (Start) address (the field can be edited when "Total" is not 
checked) 

 
 
 

⑩ "Complete" check mark: Indication of the completely 
selected memory area; all memory areas of the tag are 
always read or written at once, independent of the memory 
area currently set. 

One memory area of the most recently scanned tag is always shown in the editor. In the 
drop-down list box [③], you can select and display the different memory areas of the tag. If 
you check "Complete" ⑩, the current memory area will be displayed complete in the editor, 
otherwise you can enter values under "Address" [⑨] and "Length" [⑩] to display the 
relevant data area only.  
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The "current area" 
 
Current area  Description 

 
 

If "Complete" is not checked, the area is displayed that is specified 
in the fields "Address" and "Length". 
You can reach the individual addresses using the input pen. If you 
change the values, they will have a green background. The green 
background remains until the data are transferred/written to the 
transponder. The color green therefore indicates that the actual tag 
data differs from the values visible in the editor. 
All other data areas of the tag are shown against a white 
background.  

Memory area ISO 18000-6C (EPC Class1 Gen2) 
● USER: 

User data area. Freely available, 
its size or presence is specific to the manufacturer. 

● EPC: 

Memory area in which, for example, the tag ID is stored. 
The area is read-only. 

 

① PC: 2 bytes of Protocol Control bits 

② EPC: 12 bytes tag ID (in this example: 
30112233445566778899AAC0) 

 
 

③ CRC: 2 bytes of check sums 
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● TID: 

Memory area for tag ID (tag identifier) 

The area is read-only. 

● Reserved: 

Memory area for access password and kill password 
The area may be read only (manufacturer-specific). 

 

① Kill password 

 
 

② Access password 

For further information on the detailed structure of the different areas, see "EPCglobal-
Specification for RFID Interface" (EPCTM Radio-Frequency Identity Protocols Class-1 
Generation-2 UHF RFID Protocol for Communications at 860 MHz - 960 MHz, Version 1.0.9) 

9.4 The functions in the "File" menu 

9.4.1 Overview of file functions 
The following file functions are available that you can select in the menu via "File":  

● Open 

● Save Tag 

● Save Tag As 
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● Append List 

● Exit 

 
Figure  9-1 The file functions 

9.4.2 Open 
You can load a file via "File > Open" if the file was saved beforehand with the command "File 
> Save" or if it was transferred from the PC to the "Flash Disk" directory of the SIMATIC 
RF680M (also see Data transfer between the PC and mobile reader (Page 88)).  

All the files of the "Flash Disk" folder are displayed. You can select the desired file via the 
touch screen or by entering the filename under "Name" and <OK>. 

9.4.3 Save Tag / Save Tag As 
Via "File > Save", you can save data currently displayed in the editor of the reader to a file on 
the SIMATIC RF680M. If you select "Save", the current file will be replaced; if you select 
"Save Tag As", you can select a new directory or a new file name.  

The filename can be up to 100 (alphanumeric) characters in length. XML format is used 
automatically for saving. Also refer to the Chapter "File storage on the RF680M (Page 87)" 
as well as "Organization of the .XML files in the Flash Disk directory (Page 90)". 

9.4.4 Save List As 
When you have scanned one or more tags, you can save the tag IDs that are currently 
displayed in the form of a list. Select "File > Save List As" for this purpose. Select a directory 
and name the file. It will be saved in XML format.  

See Chapter Organization of the .XML files in the Flash Disk directory (Page 90) 
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9.4.5 Append List 
When you have already saved a list of scanned tags and you want to expand them, select 
"File > Append list" in the menu. The old data are not overwritten in this case, but simply 
added to. 

The size of the list is limited to the available storage space. 

9.4.6 Exit 
You can exit the SIMATIC RF680M program using "File > Exit" or the <ESC> key. You then 
reach the WinCE operating system level of the PSION Workabout Pro. You require the 
password relevant to the application for this, if you have previously assigned one. 

9.5 The functions in the "Tag" menu 

9.5.1 Overview of tag functions 
The following tag functions are available that you can select in the menu via "Tag": 

● Scan 

● Read Data 

● Write ID 

● Lock Tag 

● Kill Tag 

● Tag type 

 
Figure  9-2 The tag functions 
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9.5.2 Scanning RFID tags and their tag ID 
To scan one or more tags and their IDs, click the "Scan" button. 

You can also activate the "Scan" function by other means: 

● Via the keystroke combination <Ctrl +S> 

● Via "Tag > Scan" in the menu, then click the "Scan" button 

● Via the white <Scan> buttons mounted on the side of the device. See Chapter Key 
functions (Page 25) Key(s) ③. 

 
Figure  9-3 "Scan" button 

The tag IDs (in Hex) appear in the display: 

 
Figure  9-4 Scan tag 

Only newly scanned tags or their IDs are added, i.e. IDs are not entered twice in the ID list. 

Depending on the setting mode, you can acquire one or more tags at the same time. For 
detailed information on scanning mode, see Chapter Settings (Page 80). 

The time-out display appears when a tag has not been scanned for 20 seconds. 

Archiving scanned tags 
To save the list of scanned tags, select "File > Save List As" in the menu. 
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Further processing of scanned tags 
To process the data scanned from a tag, click the "Data" button or select "Tag > Data" from 
the menu. You can read the tag data, write new data to the tag or copy the tag data. 

 

 Note 
Tags without tag ID 

If a tag does not have a tag ID, it cannot be scanned and indicated. 
 

9.5.3 Progress and timeout display 
The tag functions carry out communication with the transponder. They indicate the progress 
of the currently executing function and any timeout, if applicable: 

Progress display in the case of the tag function 
During data transfer, the progress of the executing function is displayed in the form of a bar 
display:  

 
Figure  9-5 Progress display 

The tag function is not interrupted if you briefly move the tag out of the read field.  
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Timeout display in the case of the tag function 
If the tag remains unedited for longer than 20 seconds, the function is interrupted and a 
message window appears: 

 
Figure  9-6 Timeout display 

You can now stop the command completely with "Yes" or continue it with "No". If you 
continue, the interrupted command is continued at the point of interruption. 

9.5.4 Read tag 
 

 Note 
Distance limits between the tag and the reader 

Please observe the maximum distance limits between the reader and the tag when reading a 
tag. These depend on the:  
• Tag type 
• Ambient conditions / fixing method of the tag. 

Under favorable conditions, the limit distances are 250 cm. 
For additional information, see Technical data (Page 97). 
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Read tag data  
If you click the "Read" button in the data editor (or press <Ctrl+R>), you can read the data 
from the tag. The read-in data appears in the editor. 

 
"Read" button 

Reading the data area of a tag  
In the data editor, you can use the drop-down list box to select the required memory area of 
the tag whose data you want to read, and reduce it, if required, by removing the check mark 
from "Complete" and entering the address and length in the respective fields.  

Read complete tag 
If all memory areas of the tag are to be completely read or written together, set the check 
mark for "Complete".  

With this function you can display the complete size of the selected memory area. 

If the check mark is set for "Complete", "Read all" and "Write all" are displayed on the 
buttons. 

 
Figure  9-7 "Read All" button 

 

 Note 
ID check 

It is checked for all tags before any read or write procedure whether the tag ID displayed in 
the editor corresponds to the ID of the tag that is located in the field of the SIMATIC 
RF680M. If this is not the case, time-out will be displayed after 20 seconds. 
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See also 
Settings (Page 80) 

9.5.5 Writing to the tag 

Write tag data  
If you click the "Write" button in the data editor (or press <Ctrl+W>), you can write the data 
that is currently displayed in the editor to the tag.  

 
"Write" button 

Writing the data area of a tag 
In the data editor, you can select the required memory area of the tag in which you want to 
write data, and reduce it, if required, by removing the check mark from "Complete" and 
entering the address and length in the respective fields.  

Writing the complete tag 
If all memory areas of the tag are to be completely read or written together, set the check 
mark for "Complete".  

With this function you can display the complete size of the selected memory area. 

If the check mark is set for "Complete", "Read all" and "Write all" are displayed on the 
buttons. 

 
Figure  9-8 "Write All" button 
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 Note 
ID check  

It is checked for all tags before any read or write procedure whether the tag ID displayed in 
the editor corresponds to the ID of the tag that is located in the field of the SIMATIC 
RF680M. If this is not the case, time-out will be displayed after 20 seconds.  

 

See also 
Settings (Page 80) 

9.5.6 Copying tag data 
You can use this function to transfer data, for example, from one tag to another.  

Procedure for copying data  
To copy data from one tag to another, proceed as follows: 

1. Scan the tag ID of the tag from which you want to copy data, as described in the Chapter 
Scanning RFID tags and their tag ID (Page 65). 

2. From the list of tag IDs, select the ID of the transponder whose data you want to copy. 

3. Click the "Data" button. The data editor is displayed. 

4. Click the "Read" button to display the data of the currently scanned tag in the editor. 

5. Click on the "Copy" button: 

 
6. The window for scanning tags is displayed. 

7. Scan the tag to which you want to copy the data. 

8. From the list of tag IDs, select the tag (or the ID) onto which you want to copy the data. 

9. Click the "Copy" button. The data will be transferred to the tag. 
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9.5.7 Write ID 
You can change the ID of a tag using the function "Write ID".  

Select "Tag > Write ID" for this purpose. The following window is displayed.  

 
Figure  9-9 "Write ID" window 

Enter ID 
Enter the desired ID.  

It must be possible to divide number of ID characters by four. 

Transferring the ID to the transponder 
Click the "OK" button to transfer the ID to the tag. 

"Access Password" field 
When the tag to be written is protected with an access password, you must enter the 
password in the "Access Password" field. 

 

 Note 
Only keep one tag in the scanning range of the SIMATIC RF680M 

Ensure that only one tag is in the scanning range of the SIMATIC RF680M when the tag ID 
is being written. Otherwise, the tag will not be written. 

 

9.5.8 Locking data areas 
You can lock a tag by means of the "Lock Tag" function.  
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Select "Tag > Lock Tag..." for this purpose. The following window is displayed. 

 
Figure  9-10 Lock Tag 

In the "Mask" line, you can select the following transponder-specific memory areas: 

● "Kill": Kill Password 

● "Acc": Access Password For memory areas EPC, TID and user memory 

● "EPC": EPC memory 

● "TID": TID memory 

● "Usr": User memory 

"Lock" 
The entries under "Mask" determine which function is executed in the action area.  

 
0 The action will not be executed 
1 The action will be executed 

 

 
Line Kill PWD Access PWD EPC memory TID memory User memory 
Mask 0/1 0/1 0/1 0/1 0/1 0/1 0/1 0/1 0/1 0/1 
Action r/w p r/w p w p w p w p 

The entry in the "Action" line specifies how the associated memory area will be locked. 

● The identifier "r/w" defines password protection for reading/writing 

● The identifier "w" defines password protection for writing (reading is permitted) 

● The identifier "p" specifies permanent locking 

All the possible combinations of "r/w", "w" and "p" are listed in the table below complete with 
their significance for the different memory areas. 
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The tag has the status "Open" when it has been identified (access without password) and 
"Secured" when its access password has been evaluated. 

 
w p Description 
0 0 The associated memory area can be written in both the "Open" and "Secured" states.  
0 1 The associated memory area can be permanently written in both the "Open" and "Secured" 

states and can no longer be locked.  
1 0 The associated memory area can only be written in the "Secured" state, but not in the 

"Open" state.  
1 1 The associated memory area cannot be written, regardless of the state of the tag. 

 

 
r/w p Description 
0 0 The associated password area can be read and written in both the "Open" and "Secured" 

states.  
0 1 The associated password area can be permanently read and written in both the "Open" 

and "Secured" states and can no longer be locked.  
1 0 The associated password area can be read and written in the "Secured" state, but not in 

the "Open" state.  
1 1 The associated memory area cannot be read or written, regardless of the state of the tag.  

This state can be used to protect the passwords on the tag from being read out and 
overwritten. 

Example 
 
 Kill PWD Access PWD EPC memory TID memory User memory 
Mask 1          1 1          1 1          1 0          0 0          0 
Action 1          0 1          0 1          0 0          0 0          0 

In the above example, the mask bits only enable the actions for the memory areas "Kill 
password", "Access password" and "EPC memory"; no change is made to the access 
mechanisms in the TID memory and user memory areas. 

The bits assigned to the mask in this example mean: 

● "Kill password":  
The kill password can be read and written by the "Secured" state, but not by the "Open" 
state.  
You must know the access password of the tag to read or write the kill password. 

● "Access password":  
The access password can be read and written from the "Secured" state, but not from the 
"Open" state.  
You must know the access password of the tag to read or write the access password. 

● "EPC memory": 
This memory area can be written from the "Secured" state, but not from the "Open" state.  
You must know the access password of the tag to write a new ID to the tag. 
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For detailed information, please refer to"EPCglobal-Specification for RFID Interface" 
(EPCTM Radio-Frequency Identity Protocols Class-1 Generation-2 UHF RFID Protocol for 
Communications at 860 MHz - 960 MHz, Version 1.0.9) 

Displaying and executing the "Lock Tag..." function 
The current status of the action bit of a tag cannot be scanned. If the specified function 
cannot be executed, an error message will not be output directly from the tag. In this case, 
the command will only be terminated after 20 seconds with the time-out. In this case, check 
the passwords that you have entered and the bits in the mask and action lines carefully 
before you activate the command again. If the status of the available tag is not known to you, 
it is highly probable that this command will always result in a time-out. 

9.5.9 Kill tag 
You can erase a tag by means of the "Kill Tag..." function.  

The prerequisites for this are: 

● The tag must have a valid kill password (non-zero) 

● The password is entered in the interface in the "Kill Password" field. 

Select "Tag > Kill Tag..." for this purpose.  

The following window is displayed. 

 
Figure  9-11 Kill tag 
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9.5.10 Tag Type Selection 
If you want to select the tag type, proceed as follows: 

Select "Tools > Tag Type".  

The following window is displayed. 

 
Figure  9-12 Window for tag type selection 

Different types of tag are supported: 

 
Tag type 1) Corresponding exemplary RF600 tags 
EPC_GEN2_(ISO18000-6C) RF630L 

RF620T 
EPC_GEN2_240Bit RF680T 

RF630L_03 
RF640T_GEN2 

1) Siemens tags can be selected directly.  
For non-Siemens tags, the corresponding tag type is available for selection. 
For Gen 2 tags, you must also configure the size of the "user memory". Please refer to the technical 

tag information of the relevant manufacturer for this purpose. 

You can directly select SIMATIC RF600 tags, see the window "Tag type selection" 
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Select the corresponding tag. The following window appears: 

 
Figure  9-13 Enter user memory 
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9.6 The functions in the "Extras" menu 

9.6.1 Overview of the Extras functions 
The Tools menu contains the following functions that you can select via "Tools":  

● Password (application password) 

● Reader status 

● Reader settings 

● Settings 

● Language 

 
Figure  9-14 The "Tools" functions 
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9.6.2 Password for the SIMATIC RF680M application 
As an option, you can assign a password for the SIMATIC RF680M application.  

Select "Tools > Password" from the menu.  

 
Figure  9-15 Password 

1. Enter a password with up to 8 characters under "New Password". 

2. Then enter the password again under "Confirm password". 

3. Select the "OK" button. 

The password is now set. All write functions to a tag are now protected by this password. 

If you want to perform a write function now, you must enter the appropriate password. You 
only have to enter the password once in the case of several consecutive write commands. It 
will remain valid for 5 minutes after the last write function is executed. 

This password is also required to exit the application.  

Default password 
No password is assigned in the delivery condition. 

 

 Note 
Forgot password? 

If you have forgotten your password, the original status of the device can be restored. See 
System reset (Page 93) 
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9.6.3 Reader status 
Version statuses and settings of the RF600 read/write device can be read out with the 
"Reader Status" function. 

● API version 

● Model (US or EU) 

● Firmware version of the RFID module. 

 
Figure  9-16 Reader status 

9.6.4 Reader settings 
With the "Reader settings ..." function you can make the following settings: 

● Change the reader's antenna performance 

● Set the modulation pattern of the radio profile 

● "Initial Q" value setting. This value defines the number of tags expected to be in the 
measuring field at the same time. A suitable selection permits a faster detection of tags in 
the field by the reader. 

The following relation applies:  

2Initial Q = number of expected tags. 

● Select the transmit channel for the European radio profile (ETSI). 

Select "Tools > Reader Settings ..." to parameterize these settings.  
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The "Reader Settings" window opens: 

 
Figure  9-17 Reader settings 

9.6.5 Settings 
You can make the following settings using this function:  

● Setting scan mode 

● Specifying the write and read area of a tag 

● Setting data formats. 

Select "Tools > Settings" to parameterize these settings. The "Settings" window opens: 

 
Figure  9-18 Settings window 
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Settings in "Scan mode" 
Here, you can choose between single tag and bulk scanning.  

● With "Single Tag", the tags are only scanned until a tag ID is detected. 

● With "Bulk", the device will constantly try to scan additional tag IDs (until time-out or 
manual interruption of the command). 
This setting is appropriate, for example, if you are searching for a specific tag in a field 
that contains several tags. 

Settings under "Format" 
You can set different formats (for the editor, data, address and length) under "Format" that 
are explained below. 

● Effect of the "Editor" settings:  
Byte, binary  
Depending on the format that you select, the interface in the data editor is as depicted 
below: 

 
Presentation in the data editor for the settings 

"Byte" "Binary" 

  
Presentation in bytes Presentation with "0" and "1" 

● Effect of the "Data" settings:  
Hexadecimal, decimal or ASCII number format 
"Hex" or "Dec" presentation format can be recognized in the "Address" and "Length" lines 
in the data editor. 
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Hex Dec ASCII 

   

 

● Effect of the settings under "Address" and "Length" 
If there is no check mark, you can also enter decimal data here. If you subsequently set 
the check mark, the data will be converted into hexadecimal format. Depending on the 
format setting, the values will be changed in the editor. 
You can see from the data editor whether "Hex" or "Dec" is activated; for Hex format, "0x" 
is shown for "Address" and "Length": 

 
 "Hex" check mark not activated "Hex" check mark activated 
Display in the 
editor   

Settings under "Auto-Save Filename" 
Under "Auto-Save Filename" you can define whether the same file with the same name is 
always updated when scanning tags, or whether new files are saved in each case.  

 
Figure  9-19 Auto-Save Filename 
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● "READ.XML" 

If the setting "READ.XML" is selected, the same file READ.XML is always updated each 
time tag data is read.  

● "Tag_xxx.XML" 

If the setting "Tag_xxx.XML" is selected, a new file with the name TAGxxx.XML is created 
each time tag data is read. "xxx" is replaced by the ID of the read tag.  

If a tag with the same ID is read again, the corresponding file is overwritten. 

"READ.XML" is set as the default value. 

See also 
The data editor (Page 60) 

9.6.6 Setting the language 
You can set the following menu languages for operating the application : 

● English 

● German 

Procedure for selecting the language 
Select the desired language in the "Language selection" window of the "Tools > Language" 
menu and confirm with "OK". 

 
Figure  9-20 Language selection window 
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9.7 The functions in the "Help" menu 

9.7.1 Overview of "Help" menu 
The "Help" menu contains the following function that you can select via "Help":  

"About": 

 
Figure  9-21 "Help" menu 

Using "Help > About" you can obtain information on the following points:  

● Information about the device: EU or US version 

● Software version 

● Manufacturer of the application Siemens AG 

9.8 Application example 
Typical application cases for SIMATIC RF680M are shown below.  

Starting the software 
To start the SIMATIC RF680M application, click the "RF680M" icon on the desktop. 

Setting the language of the SIMATIC RF680M application 
Select the desired language in the "Language selection" window of the "Tools > Language" 
menu and confirm with "OK". 
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Prerequisites for working with transponders: Set tag type 
Select the appropriate transponder type using "Tools > Tag Type". 

 
Figure  9-22 Window for tag type selection 

Confirm with <OK>. 

Scan tag 
To scan the tag and its ID, press the white <Scan> key on the side of the device or click the 
"Scan" button on the display. The following window is displayed. 

 
Figure  9-23 Scan tag 

To read, write or copy the tag data, click the "Data" button.  
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Save tag ID list 
To save the list of all scanned tags, select "File > Save List As" in the menu. Select a 
directory and name the file. It will be saved in XML format. 

Read tag 
To read the data of the scanned tag, select the "Read" button in the data editor (or 
<Ctrl+R>). The read-in data appears in the editor. 

Write to the tag 
When writing data to the scanned tag, the data that is currently displayed in the editor is 
written to the tag. Click the "Write" button in the data editor for this purpose (or <Ctrl+W>).  

Copying tag data 
See Chapter "Copying tag data (Page 70)". 
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Advanced functions  10
 

When you are using the SIMATIC RF680M as a stand-alone product or in "Mobile" operating 
mode (configured as editable through the "Edit Tag" function in RF-MANAGER), you can use 
the extended functions of the SIMATIC RF680M that are described below. 

10.1 File storage on the RF680M 

Storing the read tag data using the data editor  
The data read from the tag are automatically stored on the mobile reader to a file with the 
name "READ.xml" in the "Flash Disk" directory.  

Every subsequent read command overwrites this file. 

Length of the written tag data 
When writing to the tag, the write data are written from the Editor to the tag and also to the 
"Flash Disk" folder of the mobile reader under the name "WRITE.xml". Every subsequent 
write command overwrites this file.  

Display Files 
The function "File > Open" shows all files with the extension ".xml". You can select one of 
these. This file is then loaded into the Editor. The file is not saved with the name READ.xml 
or WRITE.xml. 

Save files 
The function "File > Save / Save Tag As" saves the data from the Editor to a file with the 
extension ".xml" in the "Flash Disk" directory of the reader. You can enter any name with 1 to 
8 alphanumeric characters. 

 

 Note 

When you read the data from the tag, modify them in the Editor and then save them, the 
modified data are saved to the .xml file. 
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10.2 Data transfer between the PC and mobile reader 

10.2.1 Prerequisites 
If you want to access the supplied files and documentation, please not the following 
prerequisites:   

● USB driver for PSION Workabout Pro 

● You will find the USB driver 

– of PSION (http://www.psionteklogix.com). 

– On the CD "RFID Systems Software & Documentation" (Order No. 6GT2080 2AA10, 
as of 07/2007 Edition) 

● The "Active Sync" program from Microsoft 

You can download the current version of Microsoft Active Sync from the Internet at  

Microsoft homepage (http://www.microsoft.com). 

● A USB cable for connecting the PC to the SIMATIC RF680M (included in the scope of 
supply of the docking station) 

10.2.2 Working with the Active Sync program 
The ActiveSync program provides a connection via the USB to RF680M . You can now copy 
data and programs very easily in the manner familiar from Explorer. You only have to select 
the point "Mobile Device" in Explorer. It is also possible to access ActiveSync directly from 
the SIMATIC RF680M device.  

Requirements for opening the RF680M workstation 
● The USB driver for the PSION Workabout Pro is installed. 

● The Active Sync program from Microsoft is installed. 

● The SIMATIC RF680M is connected to the PC in the docking station and via the USB 
cable. 

http://www.psionteklogix.com/�
http://www.microsoft.com/�
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Opening the RF680M workstation via Explorer and Mobile Device:  
Select "Mobile Device" in Explorer: 

 
Figure  10-1 Opening the RF680M workstation via Explorer 

Then select the "Flash Disk" folder. 

Opening the RF680M workstation via ActiveSync and "Explore"  
Select the button "Explore" (button for German installation: "Durchsuchen") to access 
ActiveSync on the device.  

 
Figure  10-2 Access to the SIMATIC RF680M device via Active Sync "Explore" 
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Opening the RF680M workstation / "Flash Disk" directory 
Then select the "Flash Disk" directory and open it: 

 
Figure  10-3 Select the Flash Disk folder 

The following window is displayed. 

 
Figure  10-4 Flash disk folder 

There you will find the file "READ.XML" and the files you have stored with the extension 
".XML". You can now drag and drop or copy these files from the drive of the RF680M to the 
PC drive. 

The contents of the file can now be displayed and modified using the relevant editor on the 
PC. 

You can use any editor to display the XML structure: Notepad, Write, Microsoft Word or 
Microsoft Internet Explorer. 

10.2.3 Organization of the .XML files in the Flash Disk directory 
The XML structure for the stored "Tag data" as well as the tag ID list is shown below. 
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XML structure of the read or written tag data   
 

 
① Selected tag type 

② Tag ID 

③ Data area of the tag 

④ Start address of a 4-byte block (decimal format) 

⑤ Value of the 4 bytes of a data area (decimal format). 
• Value 1 = Start address + 1 
• Value 2 = Start address + 2 
• Value 3 = Start address + 3 

⑥ These values are hidden in this example with "Internet Explorer"; by clicking on the "+" character, the view that is 
used for the "User" data area can be displayed. 
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XML structure of the tag ID list   
 

 
① Structure that has arisen from the initial "Save List". Two tags are read. 

② Device 

③ Tag type 

④ Tag ID 

⑤ Structure that has arisen from the second save of "Append List". Three tags are read. 

Presenting the XML file in Excel   
You can also open the XML file with Excel to obtain a tabular display: 

 
Figure  10-5 XML file in Excel 
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10.3 The automatic power-saving function 
The SIMATIC RF680M has an automatic shutdown function. This is activated if no key on 
the reader is pressed for approximately three minutes.  

In addition, the "SIMATIC RF680M" software has a further power-saving function. If no tag is 
detected for 20 seconds after starting a tag command, or if the tag currently being edited 
exits the field for longer than 20 seconds, the current tag command is interrupted. The 
following message appears (see also Progress and timeout display (Page 66):  

 
Figure  10-6 Timeout display 

You can now stop the command completely with "Cancel" or continue it with "Retry". If you 
continue, the interrupted command is continued at the point of interruption. 

10.4 System reset 
After inserting the batteries and switching on for the first time, the reader carries out a 
system reset. This reset is the same as a hardware reset. 

A system reset can also be performed manually.  

The saved back-up status of the device can be restored.  

Requirements for the system reset:    
● The "Flash Disk" directory contains the backup file with the extension *.pfl 

● The devices must be in the "Supervisor" operating mode. See Operating modes 
(Page 22). 
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Performing a system reset and importing a back-up file  
You can activate a system reset via "Start > Shutdown > Cold Reset". The most recently 
saved back-up file will then be copied back in. Please note that during a "Cold Reset", the 
device restarts twice. 

To restore a backup, replace all the data in the "FlashDisk" directory with your backup copy 
and then run a system reset. 

 
 

 Note 
Data retention and data loss during system reset 

When you perform a system reset, only the saved data in the flash memory are retained 
("Flash Disk" directory). All other data in RAM (e.g. in the "Application Data" folder) is lost. 

 

 
 

 Note 
Restoring the delivery status of the device 

If you want to restore the delivery status of the device, delete the self-stored files in the 
"Flash Disk" directory, especially the self-created back-up files with the ending *.pfl. 

Ensure that the "Flash Disk" directory still contains the files that were supplied on delivery 
(especially the files with the ending *.pfl). Otherwise, you will have to copy in the files that 
were backed up on initial commissioning again. 

 



 

SIMATIC RF680M Mobile Reader 
Operating Instructions, 06/2011, J31069-D0241-U001-A2-7618 95 

Troubleshooting  11
 

 
Problem Possible cause Problem recovery 
The display goes blank when 
reading/writing. 

The battery or the batteries of the 
reader are empty. 

Insert the device into the charging and docking 
station or insert new batteries. 

The display is blank after 
switching on. 

The battery or the batteries are 
empty. 

Insert the device into the charging and docking 
station or insert new batteries. 

Error messages appear that are 
not defined anywhere. 

 Remove the batteries from the basic unit and re-
insert them after 60 s. The device now has the 
delivery status. If the error persists, the device 
may have a defect. 

The tag ID of a tag is not 
scanned and does not appear in 
the list on the display. 

The tag has no tag ID. Use the tags that already have an ID. 

The supervisor password is not 
known. 

 Restore the factory state. See Chapter System 
reset (Page 93). 

The password for the write 
commands of the SIMATIC 
RF680M application has been 
forgotten. 

 Copy in the most recent back-up. 

The EPC tag has not been initialized. The tag must be initialized. 
The tag is defective. Use a different/new tag. 
The tag is too far away from the read 
head. 

Reduce the distance between the read head 
and the tag. Please observe the limit distances 
between the reader and tags. Refer to the limit 
distances in Chapter Technical data (Page 97). 

The frequency ranges of tag and 
reader do not match. (US; EU) 

Use a transponder that suits the RF680M read 
head.  

The tag at the read head is not 
read. 

The orientation of the tag antenna 
does not comply with the alignment 
of the reader antenna. 

Ensure correct alignment of the transponder 
antenna and reader antenna. See Antenna and 
antenna field (Page 14). 

The "Function ..." command (e.g. 
Write) was not performed on the 
tag that is situated in the field. 

The "Secured" state or a password 
have been set on the tag 

You can only perform the "Function ..." 
command when you know the exact status of 
the tag. It is not possible to read out the status 
of the tag. 
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Technical data  12
 

 
Processor   Intel Xscale PXA270- 624 MHz, ARM 
RAM 256 MB 
ROM 1 GB Flash ROM 
User program RF680M.exe 
Screen Color Touch Display, 480 x 640 pixels, portrait 
Keypad Alphanumerical 
Sound Piezo signal transmitter 
Power supply Lithium-ion battery (3.7 V; 3300 mAh) for rapid 

charging; automatic switch-off  
Interfaces LIF interface (low insertion force interface) for battery 

charging and communication with PC (USB)  
Operating system Microsoft Windows Embedded CE 5.0 
File management MS-DOS-compatible 
Technical specifications Complete unit (incl. rechargeable batteries) 
Dimensions 265 x 100 x 42 mm 
Weight Approx. 600 g 

Operation -20 °C to +50 °C Temperature 
Storage -40 °C to +60°C (without battery) 

Relative humidity 5% to 95%, no condensation  
Degree of protection IP65, IEC 60529 (splashproof) 
EMC EN55022; EN301489; EN55024 
Safety CSA/UL60950-1; IEC60950-1, EN60950-1 
RF EN 300 220; FCC Part 15 

EU: 865.6...867.6 MHz Transmission frequency 
USA: 902 to 928 MHz 

Transmit power Max. 500 mW 
Compatibility With all SIMATIC RF600 data carriers (tags) 
Read/write distance to transponder Max. 250 cm 
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Ordering data  13
 

 
Component Order No.  
Mobile reader SIMATIC RF680M 
with integrated RFID read/write unit for RF600 

ETSI: 6GT2813-0BC00 
FCC: 6GT2813-0BC10 

 

 
Accessories  Order No. 
SIMATIC RF reader charging/docking station. 
Charging station for Workabout PRO 
Incl. wide-range power supply unit with universal adapter, power cable and 
USB cable 

6GT2898-0BA00 

SIMATIC RF WLAN module for mounting on RF680M 6GT2898-0DA00 
SIMATIC RF barcode scanner for mounting on RF680M 6GT2898-0DB00 
Replacement battery 3300 mAh  6GT2898-0CA00 
CD "RFID Systems Software & Documentation" 6GT2080-2AA10 
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Appendix  A
A.1 Certificates and approvals 

 
Certificates and approvals Description 
Certificates 

 
CE approval to R&TTE 

Approvals 
FCC  
Federal Communications 
Commission  

GM3UHFCA3A5 

A.2 Ordering components for advanced functions 
The advanced functions of the SIMATIC RF680M reader require additional components from 
PSION Teklogix that are not supplied by Siemens. 

If you require these components for your application, please contact PSION direct or its 
representative in your country. Addresses and ordering lists of PSION can be found on the 
Internet at PSION homepage (http://www.psionteklogix.com). 

You can also find the PSION agent in your country at this Internet address.  

In Germany, PSION components are supplied by WAROK (Tel. -49 7721/202630). 

A.3 Developing user applications 
User applications require the SDK development package from PSION (PSION Teklogix 
Mobile Devices SDK for MS Visual Studio, Microsoft and Visual Studio 2005). 

You will find further details in the function manual for SIMATIC RF680M that is also  

saved in the "Flash Disk" directory of the RF680M.  

A.4 Service & support 

Contact partner   
If you have any further questions on the use of our products, please contact one of our 
representatives at your local Siemens office.  

http://www.psionteklogix.com/�
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The addresses are found on the following pages: 

● In Internet (http://www.siemens.com/automation/partner) 

● In Catalog CA 01 

● In Catalog ID 10 specifically for industrial communication / industrial identification systems 

Technical Support   
You can access technical support for all IA/DT projects via the following: 

● Phone: + 49 (0) 911 895 7222 

● Fax: + 49 (0) 911 895 7223 

● E-mail (mailto:support.automation@siemens.com) 

● Internet: Online support request form: (http://www.siemens.com/automation/support-
request) 

Service & support for industrial automation and drive technologies 
You can find various services on the Support homepage 
(http://www.siemens.com/automation/service&support) of IA/DT on the Internet.  

There you will find the following information, for example: 

● Our newsletter containing up-to-date information on your products. 

● Relevant documentation for your application, which you can access via the search 
function in "Product Support". 

● A forum for global information exchange by users and specialists. 

● Your local contact for IA/DT on site. 

● Information about on-site service, repairs, and spare parts. Much more can be found 
under "Our service offer". 

RFID homepage 
For general information about our identification systems, visit RFID homepage 
(http://www.siemens.com/ident). 

Technical documentation on the Internet 
A guide to the technical documentation for the various products and systems is available on 
the Internet:   

SIMATIC Guide manuals (http://www.siemens.com/simatic-tech-doku-portal)  

Online catalog and ordering system  
The online catalog and the online ordering system can also be found on the Industry Mall 
Homepage (http://www.siemens.de/industrial-controls/mall). 

http://www.siemens.com/automation/partner�
mailto:support.automation@siemens.com�
http://www.siemens.com/automation/support-request�
http://www.siemens.com/automation/support-request�
http://www.siemens.com/automation/service&support�
http://www.siemens.com/ident�
http://www.siemens.com/simatic-tech-doku-portal�
http://www.siemens.de/industrial-controls/mall�
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Training center    
We offer appropriate courses to get you started. Please contact your local training center or 
the central training center in  

D-90327 Nuremberg. 

Phone: +49 (0) 180 523 56 11 
(€ 0.14 /min. from the German landline network, deviating mobile communications prices are 
possible) 

For information about courses, see the SITRAIN homepage (http://www.sitrain.com). 

http://www.sitrain.com/�
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Glossary 

API 
Application Programming Interface (programming interface) 

Byte 
A group of eight bits form a byte. 

CE mark 
Communauté Européenne (product mark of the European Union) 

EPC 
Electronic product code 

MDS 
Mobile data memory (see transponder) 

RAM 
Random Access Memory 

Read/write devices (SLG) 
See readers 

Readers 
Readers ensure fast, secure data transfer between mobile data storage units and higher-
level systems. The data, energy included, are transmitted across an electromagnetic 
alternating field. This principle enables contact-free data transmission, ensures high 
industrial compatibility and works reliably in the presence of contamination or through non-
metallic materials. 

RFID 
Radio Frequency Identification 



Glossary  
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RFID systems 
SIMATIC RF identification systems control and optimize material flow and  
production sequences. They identify reliably, quickly and economically, use non-contact 
data communication technology, and store data directly on the product. They are also  
resistant to contamination. 

Tag 
See transponder 

TID 
Transponder identification number 

Transponder 
An invented word from transmitter and responder. Transponders are used on the product, 
the product carrier, the object, or its transport or packaging unit, and contain production and 
manufacturing data, i.e. all application-specific data. They follow the product through 
assembly lines, transfer and production lines and are used to control material flow. 

Because of their wireless design, transponders can be used, if necessary, at individual work 
locations or manufacturing stations, where their data can be read and updated. 
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Index 

  

A 
Accessories, 13, 99 
ActiveSync, 89 
Application example, 84 
Automatic shutdown, 20 
Automatic switching off, 20 

B 
Backlighting, 23 
Backup battery, 18 
Battery 

Charging, 18 
Inserting, 17 
Level of charge, 18 

C 
Charging 

Battery, 18 
Contact partner, 101 
Conventions, 7 
Copying 

Tag data, 70 
Courses, 103 
Creating a back-up copy, 20 
Current area, 37, 61 

D 
Data editor 

Interface structure, 36, 60 
Data transfer 

Reader - PC, 88 
Delivery status 

Restore, 93 
Design 

SIMATIC RF680M, 13 
Directories, 87 
Display 

Progress, 39, 66 
Timeout, 39, 67 

E 
Exit, 45, 64 

F 
Features 

SIMATIC RF680M, 11 
File 

Downloading, 63 
Exit, 45, 64 
Loading, 44 
Save, 45, 63 

File functions 
Overview, 44, 62 

File storage, 87 
Function, 57, 84 
Functions 

Overview, 12 
SIMATIC RF680M, 12 

Functions with RF680M 
Overview, 59 

Functions with RF-MANAGER 
Overview, 42 

Further information, 7 

H 
High-frequency field 

Direction of propagation, 14 

I 
ID check, 42, 70 

K 
Key combinations, 59 
Key functions, 25 

L 
Language selection, 54, 83 
LED 
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Charge indicator, 13 
Level of charge, 18 
List, 63 
List tag ID, 63 

M 
Mobile 

Operating mode, 34 

O 
ON/OFF button, 20 
Open 

via Mobile Device, 89 
via PSION workstation, 89 

Operating mode, 22 
Mobile, 34 
Remote, 33 

Order numbers, 99 
Ordering data, 99 

Accessories, 99 
Overview 

Functions with RF680M, 59 
Functions with RF-MANAGER, 42 

P 
Password 

For locking data areas, 49, 72 
For the operating system, 21 
For the RF-MANAGER application, 52 
For the SIMATIC RF680M application, 78 

Password protection, 12 
Passwords 

Overview, 12 
Performing a back-up, 21 
Power supply, 17 
power-saving function, 93 
Problem handling, 95 
Progress display, 39, 66 
PSION workstation, 89 

R 
Read 

Tag data, 40, 67 
Tag ID, 65 

Read head, 14 
Read tag, 40, 68 

Reader status, 53, 79 
Recommendations for first commissioning, 20 
Remote, 33 

Mode, 33 

S 
Save, 45, 63 
Scan 

Of tags, 65 
Scan mode, 80 
Scope of supply, 19 
Set menu language, 54, 83 
Settings 

Format, 54, 80 
Read and write area, 54, 80 
Tag scanning mode, 80 

Shift keys, 26 
Shortcuts, 59 
Software 

Overview, 27 
Start "RF680M" software,  
Starting the software "RF-MANAGER",  
Switching on the device, 20 
System reset, 93 

T 
Tag 

Copying data, 70 
Tag functions 

Overview, 46, 64 
Tag ID 

Read, 65 
Write, 47, 71 

Tag standards, 11 
Tag type 

Set, 75 
Tags 

Scan, 65 
Technical documentation 

On the Internet, 102 
Technical specifications, 97 
Technical Support, 102 
Tools functions 

Overview, 51, 77 
Training, 103 
Troubleshooting, 95 
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U 
USB driver, 88 
User applications, 101 
User mode, 22 

V 
Volume 

Acoustic signals, 23 
Volume of acoustic signals, 23 

W 
Write 

Tag data, 41, 69 
Tag ID, 47, 71 

Writing tags, 41, 69 

X 
XML file 

in Excel, 92 
XML structure 

List tag ID, 92 
Tag data, 91 
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