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Question 
How can you establish a connection between an S7-1200 PLC and SIMATIC NET 
OPC? 

 

Answer 
The instructions and notes listed in this document provide a detailed answer to this 
question. 
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1 Introduction 

1.1 Use case  

As it is not possible to create a PC Station with STEP 7 Basic V10.5, you need to 
use one of the following tools: 

• “SIMATIC NCM PC” tool of SIMATIC NET Edition 2008  

• “SIMATIC MANAGER” V5.4 SP5  

Figure 1-1 

 

1.2 Requirements 

• PG/PC  

• STEP 7 Basic V10.5  

• SIMATIC MANAGER V5.4 SP5 or 

• SIMATIC NET Edition 2008  

– NCM PC tool 

– OPC Server 

– OPC Scout 

• S7-1200 PLC 

• Ethernet Cable  

Figure 1-2 
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2 Setting up your S7-1200 PLC using STEP 7 
Basic 
Configure your S7-1200 PLC and provide data to be monitored via an OPC 
connection. 

2.1 Hardware configuration  

For the hardware configuration, use the project view of STEP 7 Basic V10.5.  

Create the project  

Select the menu command "Project > New". The dialog box "Create a new 
project" opens. Enter the name "S7-1200_OPC_SIMATIC-NET" in the 
"Project name" input field. Click the "Create" button.  

Figure 2-1 
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Add a new PLC to the project  

Double-click the project tree command “Add new device”. The “Add new device “ 
dialog box opens. In the work area, click the “SIMATIC PLC” button, and select 
your PLC by clicking its MLFB. Click the “OK” button.  

Figure 2-2 
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Change the IP address of the Ethernet port  

Double-click the project tree command “Devices & Networks”. In the “Devices & 
Networks” work area, click the “Ethernet port” of your S7-1200 PLC. 

In the navigation area of the “Properties” tab, select the “Ethernet addresses” 
instruction. Define the IP address “192.168.0.110” for the Ethernet port in the “IP 
address” input field.  

Click the “Add new subnet” button. In the “Devices & Networks” work area, you will 
find the subnet PN/IE_1 connected to your S7-1200 PLC.  

Figure 2-3 
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2.2 Software configuration  

To see value changes, you will now create a small program in which two hardware 
inputs and a hardware output of your PLC are connected to a software flip-flop. 

Add a global data block 

In the “Project tree”, click the expand button of your PLC folder (for example, 
PLC_1 [CPU 12…]). Open the “Program blocks” sub-folder by clicking its expand 
button, and double-click the “Add new block” instruction.  

In the “Add new block” dialog box, select the “Data block (DB)” button, enter the 
name “Data_block_1” in the “Name” input field, and uncheck the “Symbolic access 
only” check box. Click the “OK” button. The “Data_block_1” work area opens.  

Figure 2-4 
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Create static data in a global data block   

Create a "Bool" data type tag named “static_01” in the “Data_block_1” work 
area. 

Figure 2-5 

 

Create a program in Main [OB1]  

In the “Program blocks” folder of your PLC, double-click the “Main [OB1]” 
instruction. Copy the program shown in the next picture.  

You will find the bit logic operations in the “Bit logic” folder in the “Instructions” 
pane on the “Instructions” task card. Drag’n’Drop the “Normally open contacts”, 
“the Output coil”, and the “Set/Reset flip-flop” into “Network 1” of your “Main [OB1]” 
work area, according to the picture shown below. Make sure that the input fields 
are configured in the same way as shown in the picture and in the table.  
Figure 2-6 

 

Contacts 

Table 2-1 

SR FlipFlop input S: normally open contact I1.0 

SR FlipFlop input R: normally open contact I1.1 

SR tag DB1.DBX0.0 

SR FlipFlop output Q: output coil Q1.0 
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Note: The “%” in front of the addresses is added by STEP 7 Basic V10.5 
automatically.  

2.3 Finalize the S7-1200 PLC work 

Highlight the “PLC_1 [CPU12…]” folder in your project tree in order to compile, 
download, and run your S7-1200 PLC.  

Compile and download the program 

Press the “Download to device” button in the Toolbar.  

Figure 2-7 

 

The “Extended download to device” dialog box opens. Ensure that the selected 
PG/PC interface and subnet are correct. Select “PLC_1”. Click the “Load” button.  

Figure 2-8 

 

If you have downloaded your project before, the “load preview” dialog box may 
open instead of the “Extended download to device” dialog box.  
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Another dialog box may open, asking to stop the S7-1200 PLC for downloading. 
Acknowledge by clicking the “OK” button.  

Figure 2-9 

 

The load preview dialog box opens. Click the “Load” button.  

Figure 2-10 

 

Switch the S7-1200 PLC to run 

The load result dialog box opens. Check the “Start all” check box, and press the 
“Finish” button. Your S7-1200 PLC status LED changes from stop to run. 

Figure 2-11 
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3 Create and configure the PC-Station  
To access the data in your S7-1200 PLC via OPC, you have to create and 
configure an S7-connection in a STEP 7 project with the SIMATIC MANAGER” tool 
or with the “SIMATIC NCM PC” tool. The following description refers to the 
“SIMATIC MANAGER” tool.  

3.1 Create a new STEP 7 project  

Open your “SIMATIC MANAGER” tool. To create a new STEP 7 project, click the 
menu command “File > new”. The “New Project” dialog box opens. Write 
“S7-1200_OPC-Test” in the “Name” input field. Click the “OK” button.  

Figure 3-1 

 

3.2 Add a SIMATIC PC station  

Click the menu command “Insert > station > SIMATIC PC-Station”. A SIMATIC PC-
Station is added to your project. 

Figure 3-2 
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3.3 Add an OPC server 

Select the OPC server  

Select the SIMATIC PC-Station in the project tree, and click the menu command 
“Edit > Open Object”. The “HW Config” dialog box opens.  

Figure 3-3 

 

Click line number one of  the “(0) PC” rack in the work area. Double-click 
“SIMATIC PC-Station > User Application > OPC Server > SW V7” in the catalog. 
The OPC server is inserted into line number one of the rack.  

Figure 3-4 
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Configure the OPC server properties 

Double-click the “OPC Server” module in line number one of the “(0) PC” rack. 
The “Properties” dialog box opens. Click the “S7” tab. Set the “Use Symbols” radio 
button to “None”. Click the “OK” button.  

Note: Symbol use is not supported by S7-1200 PLCs. 

Figure 3-5 
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3.4 Add an Ethernet interface IE General  

Select the Ethernet interface  

Click line number two of  the “(0) PC” rack in the work area. Double-click “SIMATIC 
PC-Station > CP Industrial Ethernet > IE General > SW V6.2 SP1” in the catalog. 

 Figure 3-6 

 
The “Properties” dialog box opens.  



3 Create and configure the PC-Station 
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Enter the IP address  

In the “Parameters” tab, enter the IP address of your PC in the “IP address” input 
field (for example, 192.168.0.11).  

Figure 3-7 

 

Add a subnet to the Ethernet Interface  

Click the “New” button. The “Properties” dialog box for a new subnet opens.  

Figure 3-8 

 

Click the “OK” button. The subnet properties dialog box closes. Click the “OK” 
button. The Ethernet interface properties dialog box closes. The Ethernet interface 
is inserted into line number two of the rack.  
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3.5 Save and compile the PC-Station 

Click the menu command “Station > Save and Compile”.  

Figure 3-9 

 

3.6 Setup the Station Configurator 

3.6.1 Open from the Start menu 

Double-click the “Station Configurator” symbol in the task bar. The “Station 
Configuration Editor” window opens.  

Figure 3-10 

 

3.6.2 Insert the OPC Server and the IE General 

Click the “Add” button. The “Add Component” dialog box opens. Select “OPC 
Server” as the component type for Index “1”, and click the “OK” button. 
Acknowledge any dialog box that opens. 

Add “IE General” as the component type for Index “2”. Close the “Station 
Configurator Editor” dialog box by clicking the “OK” button. 
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Figure 3-11 

 

Ignore any warning and proceed by clicking the “OK” button. The import is finished. 

3.7 Set the PG/PC interface  

Click the menu command “Options > Set PG/PC Interface”. The dialog box opens.  

Figure 3-12 
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Assign the interface parameter to “PC internal (local)” and click the “OK” button.  

Figure 3-13 

 

3.8 Download the hardware configuration  

Make sure that your S7-1200 PLC is connected to your PG/PC. Open your 
“SIMATIC MANAGER” project. Select the “SIMATIC PC Station” in the project 
tree, and click the menu command “Edit > Open Object”. The “HW Config” dialog 
box opens.  

Figure 3-14 

 



3 Create and configure the PC-Station 
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Click the “Download” button in the tool bar. Acknowledge the “Select Target 
Module” dialog box by clicking the “OK” button. The “Select Node Address” dialog 
box opens.  

Figure 3-15 

 

Ensure that the IP address of your “SIMATIC PC-Station(1)”  matches the IP 
address of your PC. Click the “OK” button.  

Figure 3-16 
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4 Configure the network with NetPro  

4.1 Create an S7-connection  

Click the menu command “Options > Configure Network”. The “NetPro” window 
opens.   

Figure 4-1 

 

Select the “OPC server” slot of the “PC-Station(1)”. Click the menu command 
“Insert > New Connection”. The “Insert New Connection” dialog box opens.  

Figure 4-2 

 

Since the S7-1200 PLC is an S7 Station, we are able to use an S7-Connection. 
The partner should be “unspecified” since the S7-1200 is not available in the same 
STEP 7 project.   

Click the “OK” button. The “Properties - S7 connection” dialog box opens.  



4 Configure the network with NetPro 
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4.2 Configure an S7-connection  

Enter the IP address “192.168.0.110” of your S7-1200 PLC in the “Partner Address 
input field” of the “Properties - S7 connection” dialog box.  

Click the “Address Details” button. The “Address Details” dialog box opens. Enter 
“0” in the “Partner Rack” input field and “1” in the “Partner Slot” input field. Click 
the “OK” button. Close the “Properties - S7 connection” dialog box by clicking its 
“OK” button. Close the “Insert New Connection” dialog box by clicking its “OK” 
button.  
Figure 4-3 

 

4.3 Compile the project  

Click the menu command “Network > Save and Compile”.   
Figure 4-4 
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Download the connection 

Select the “SIMATIC PC Station (1)”. Download the connection to the “SIMATIC 
PC Station (1)” by clicking the “Download” button. Acknowledge any dialog box 
that opens. The connection should now be downloaded to your device.  

Figure 4-5 

 
 

 



5 OPC Scout 
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5 OPC Scout  

5.1 Create a new group  

Open OPC Scout. Double-click “OPC.SimaticNET” in the server tree. The “Add 
Group” dialog box opens. Enter “S7-1200_OPC_Test” in the “Group Name” input 
field. Click the “OK” button.  

Figure 5-1 

 

5.2 Select the connection and create the items  

Double-click the new group “S7-1200_OPC_Test”. The “OPC - Navigator” dialog 
box opens.  

Figure 5-2 

 

Browse the “Nodes” tree to “Connections > \S7 > S7 connection_1 > objects > I > 
[New Definition]”. Double-click the option “[New Definition]”. The “Define New 
Item” dialog box opens. 

Fill in the data as shown in the Table 5-1:  

Table 5-1 

Datatype Address Bit No. No. Values 

X 1 0 1 
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Click the “OK” button. Move the new item to the right column four times by clicking 
the “-->” button. 

Double-click on each item, and modify its name as shown in Table 5-2: 

Table 5-2 

S7:[S7 connection_1]IX1.0  

S7:[S7 connection_1]IX1.1  

S7:[S7 connection_1]DB1, X0.0, 1  

S7:[S7 connection_1]QX1.0  

Click the “OK” button to end the “OPC Navigator” window.  

5.3 View the values  

In the “Value” column, you can see the actual values of the listed items. If you are 
connected to your S7-1200 PLC, the “Quality” of the item is listed as “good”.   

Figure 5-3 
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