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Указания по технике безопасности  

В настоящем руководстве содержатся указания, на которые следует обратить внимание в целях 
обеспечения собственной безопасности, равно как и безопасности и сохранности оборудования. 
Указания, относящиеся к Вашей личной безопасности, помечаются в руководстве с помощью 
предупреждающих знаков в виде треугольника в восклицательным знаком. Указания, относящиеся к 
повреждению оборудования, не отмечены данным символом 
По степени важности различают следующие указания:  

   

Опасность  
Указывает, что несоблюдение надлежащих мер безопасности приведет к смерти или к 
серьезным травмам. 

   

Предупреждение 
Указывает, что несоблюдение надлежащих мер безопасности может привести к смерти, 
Или к серьезным травмам. 

   

Предостережение 
с предупреждающим знаком указывает, что несоблюдение надлежащих мер безопасности может привести 
к незначительным травмам. 

 Предостережение 
без предупреждающего знака указывает, что несоблюдение надлежащих мер безопасности может 
привести к повреждению имущества. 

 Замечание 
Указывает, что не принятие во внимание соответствующей информации может привести к 
непредвиденной ситуации. 
Если существует более чем одна степень опасности, то используется указание, представляющее собой 
наивысшую степень опасности. Указание о возможном травматизме может также включать в себя 
предупреждения относительно повреждения оборудования.  

 
Квалифицированный персонал 

Устройство (система) должно быть настроено и использоваться только в соответствии с данной 
документацией. Ввод в эксплуатацию м работа на устройстве (системе) могут быть выполнены только 
квалифицированным персоналом. В пределах контекста данной документации, квалифицированный 
персонал определяется как люди, которые имеют право ввода в эксплуатацию, заземления и маркировки 
электрических цепей, оборудования и систем в соответствии с действующими методами и стандартами 
техники безопасности. 

  
Надлежащее использование 

Примите во внимание следующее: 
 

   

Предупреждение 
Это устройство и его компоненты могут использоваться только для целей, описанных в каталоге или 
технической документации, и в соединении только с теми устройствами или компонентами других 
производителей, которые были одобрены или рекомендованы фирмой Siemens. 
Этот продукт может правильно и надежно функционировать только в том случае, если он 
правильно транспортируется, хранится, устанавливается и монтируется, а также 
эксплуатируется и обслуживается в соответствии с рекомендациями. 
 

 
Товарные знаки 
 
 Все наименования, идентифицированные знаком ®, являются зарегистрированными товарными знаками 

SIEMENS AG. 
Публикация торговых марок, использование их третьими лицами для собственных целей нарушает права 
владельца. 
 

 Copyright © Siemens AG 2005 Все права защищены
Воспроизведение или копирование, передача или использование этого 
документа или его содержания не разрешаются без специального 
письменного разрешения. Нарушители будут нести ответственность за 
нанесенный ущерб. Все права, включая права, вытекающие из патента 
или регистрации практической модели или конструкции, сохраняются. 
 

 Ограниченная ответственность 
Мы проверили содержание этого руководства на соответствие с 
описанием аппаратных средств и программного обеспечения. Так как 
отклонения не могут быть полностью исключены, то мы не 
можем гарантировать полного соответствия. Однако данные, 
приведенные в этом руководстве, регулярно пересматриваются, 
и все необходимые исправления вносятся в последующие 
издания.  
 

Siemens AG 
Департамент автоматизации и приводов 
Промышленные системы автоматизации 
П/я 4848, D- 90327, Нюрнберг  

©Siemens AG 2005 
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Первые шаги ввода в эксплуатацию 

Введение 
Данная инструкция показывает Вам, как вывести сообщения от CP 340 на принтер, шаг 
за шагом, на основе конкретного примера. В процессе Вы также узнаете основные 
функции драйвера принтера CP 340. 

Время, необходимое Вам для усвоения  примера составляет 1 - 2 часа, в зависимости 
от Вашего опыта, плюс время, необходимое для приобретения, монтажа и подачи 
вспомогательного питания. 

 

 
Предупреждение 
 
Эксплуатация Вашего PLC в качестве части установки или системы требует 
выполнения определенных правил и стандартов, зависящих от области применения. 
Соблюдайте соответствующие стандарты по обеспечению безопасности и 
предотвращению несчастных случаев, например, IEC 204 (Устройства аварийного 
отключения).  
Несоблюдение этих стандартов может привести к травмам, а также к повреждению 
машин и оборудования. 

 
 

 

 
Предупреждение 

Вы можете касаться кабелей и проводов, находящихся под напряжением, если блок 
питания вашего PLC включен или если кабель питания подключен к электросети. 

Подключайте Ваш PLC только в обесточенном состоянии. 
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Требования: 
• Контроллер S7-300, состоящий из 

– Стойки 

– Блока питания 

– Центрального процессора (CPU) 

– CP 340 с портом RS 232C принтера 

• IBM-совместимый принтер с интерфейсом RS 232. Принтер для последовательной 
передачи данных подключен с помощью соединительного кабеля RS 232 к CP 340.  
Соответствующее конфигурирование принтера должно быть выполнено только 
обученным персоналом. 

• STEP 7 V5.1+ Service pack 2, правильно установленные на программаторе. 
Убедитесь, что все компоненты совместимы, от операционной системы и ее сервис-
пакетов до пакета STEP7 с его обновлениями. 

• Установленный пример проекта вывода на принтер для станции S7–300. 

• Программатор, подключенный к центральному процессору (CPU) PLC. 

 
Рисунок 1-1 Пример установки 

 
 1. Блок питания 
 2. Центральный процессор CPU 3xx 
 3. CP 340 
 4. Соединительный кабель RS 232 / CP 340 - принтер 
 5. IBM-совместимый принтер 
 6. Программатор 
 7. Соединительный кабель MPI / CPU - программатор 
 8. Станция S7-300  
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Цели документа "Первые шаги": 
Задание, описываемое в данном документе состоит в том, чтобы вывести на принтер 
следующие сообщения: 

• В xx:xx:xx.xxx достигнут предел 1500 литров 

• В xx:xx:xx.xxx превышен предел 1500 литров 

• В xx:xx:xx.xxx предел меньше, чем 1500 литров 

Где xx:xx:xx.xxx является текущим временем дня. 

Сообщения создаются в начале работы с проектом "Первые шаги", используя формат 
строки с 3 переменными: 

 
Где: 

• %Z: переменная инструкция для типа данных TIME_OF_DAY 

• %i: переменная инструкция для типа данных INT, WORD, DINT, DWORD 

• %N: переменная инструкция для вывода сообщения, сконфигурированного в HW 
Config 

В проекте "Первые шаги" 

• Формат строки определен в DB 10, 

• Переменные 1, 2 и 3 определены в DB 6, 7 и 8, 

• DB 5 содержит указатель на блоки данных с 6 по 10. 

1. Шаг: Установка конфигурационного программного обеспечения в программатор 
Конфигурационное программное обеспечение содержит функциональные блоки, 
необходимые для работы с вашей пользовательской программой, а также примеры 
программирования. 

Конфигурационное программное обеспечение также может находиться 

• На поставляемом CD 

• В Internet на сайте: http://www.ad.siemens.de/simatic-cs. Заказной номер (Contribution 
ID): 12310504 

 
Шаг Действие Результат 
1 Запустите программу установки двойным щелчком на файле 

SETUP.EXE в папке SETUP. 
Программа установки запущена. 

2 Следуйте инструкциям, выдаваемым программой установки.  
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2. Шаг: конфигурирование CP 340 
 
Шаг Действие Результат 
1 Откройте Ваш проект в SIMATIC Manager.  
2 В Вашем проекте вызовите конфигурационный инструмент 

HWCONFIG. 
 

3 Дважды щелкните на CP340 RS232C. Откроется диалоговое окно "CP 340-RS232C 
properties". 

4 Обратите внимание на адрес модуля в закладке "Addresses". Это 
значение необходимо как параметр, который задается при 
вызове FB P_PRINT в Вашей пользовательской программе. 

 

5 Щелкните на кнопке Parameters. Откроется диалоговое окно "Configure point-to-
point coupling CP 340-RS232C". 

6 Выберите протокол PRINTER и подтвердите выбор, нажав Yes. Протокол принтера загружается со 
следующими установками по умолчанию: 9600 
бит/с, 8 бит данных, 1 стоповый бит, 
положительная четность, отсутствие 
управления потоком данных, активация 
мониторинга BREAK. 

7 Дважды щелкните на вкладке Protocol. Открывается диалоговое окно "Protocol". 
8 При необходимости, настройте установки по умолчанию с 

протоколом Вашего принтера и подтвердите, нажав OK. 
 

9 Дважды щелкните на page layout. Открывается диалоговое окно "Page layout". 
10 Задайте параметры страницы и подтвердите, нажав OK.  
11 Дважды щелкните на Messages, а затем на SDB. Откроется диалоговое окно "Messages". 
12 Назначьте имя максимум из 8 ASCII символов для текста SDB.  

Последовательно введите следующие номера сообщений и 
тексты сообщений в "Edit message:", нажимая кнопку Enter после 
каждого ввода. 
Номер Текст 
0 достигнут 
1 превышен 

13 

2 меньше, чем 

Тексты сообщений, введенных в "Edit 
message:", импортируются в обзор текстовых 
сообщений  "Message texts". 

14 Щелкните на кнопках управления OK и SDB. Диалоговое окно "Messages" закроется. 
15 Сохраните конфигурацию с помощью File > Save и выйдите из 

диалогового окна конфигурации с помощью File > Exit. 
 

16 В диалоговом окне "Properties CP 340-RS232C" щелкните на 
кнопке OK. 

 

17 Сохраните созданную Вами конфигурацию с помощью Station > 
Save в Ваш проект  и скомпилируйте  . 

 

18 Загрузите конфигурацию в CPU в режиме STOP, выбрав PLC > 
Download to Module. 

Данные загружаются непосредственно в CPU 
и CP 340. Выключение индикации светодиода 
"SF" говорит об успешном завершении 
загрузки. 

19 Используйте  Station > Exit для закрытия HWCONFIG.  
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3. Шаг: создание блоков  
 
Шаг Действие Результат 
1 В SIMATIC Manager в каталоге Siemens\STEP7\S7libs\CP PtP 

используйте File > Open ... > Libraries для открытия библиотеки 
CP 340 и вложенной в нее папки Blocks.  

Открывается разделенное на две 
части окно с заголовком библиотеки и  
FB и FC для CP 340. 

2 Скопируйте FB 4 в папку блоков Вашего проекта.  
3 В SIMATIC Manager используйте File > Open ... > Libraries в 

каталоге Siemens\STEP7\S7libs\StdLib30 для открытия списка 
блоков библиотеки IEC Function Blocks. 

Открывается разделенное на две 
части окно с заголовком библиотеки и 
функциями IEC. 

4 Скопируйте FC 8 в папку блоков Вашего проекта.  
5 В SIMATIC Manager используйте File > Open ... > Libraries в 

каталоге Siemens\STEP7\S7libs\StdLib30 для открытия списка 
блоков библиотеки IEC Function Blocks.. 

Открывается разделенное на две 
части окно с заголовком библиотеки и 
SFB и SFC. 

6 Скопируйте SFC 1 в папку блоков Вашего проекта.  
С помощью Insert > S7 block > Data blocks создайте в папке 
блоков Вашего проекта следующие блоки данных: 
DB Назначение в проекте для вывода на принтер 
DB 5 Указатель DB 
DB 6 DB для переменной 1 
DB 7 DB для переменной 2 
DB 8 DB для переменной 3 
DB 9 DB для переменной 4 

7 

DB 10 DB для переменной строкового типа  

 

8 В папке блоков Вашего проекта используйте Insert > S7 block > 
Variable table для создания таблицы переменных VAT_1. 

 

 



Первые шаги ввода в эксплуатацию  

 CP 340 PtP Драйвер принтера 
1-6 04/2005, A5E00369899-01 

4. Шаг: вызов блоков в OB 1 
 
Шаг Действие 
1 В Вашем проекте откройте OB 1. 
2 В таблице объявлений создайте переменную "Time" с типом данных DATE_AND_TIME.  

В OB 1 вызовите SFC 1, FC 8 и FB 4 и назначьте параметры для блоков следующим образом: 
CALL  "READ_CLK" SFC1 //Чтение даты и времени 

 RET_VAL  :=MW3   
 CDT  := #Time  Ввод //даты и времени в переменную "Time"  

CALL  ”DT_TOD" FC8 //Преобразование даты и времени во время дня 
 IN  := #Time   

 RET_VAL  := DB6.DBD0  //Область для времени дня (Переменная 1 в DB 6) 
CALL  ”P_PRINT", DB4 FB4 //FB для вывода на принтер текстов сообщений 

 REQ  :=M1.0  Стартовый бит, используется положительный 
фронт 

 R  :=  //Бит сброса 
 LADDR  := 256  //Адрес модуля CP 340 (из HW Config) 
 DB_N0  := 5  //Указатель номера блока данных 

 DBB_N0  := 0  //Указатель начального байта в DB 
 DONE  := M1.1  //Работа завершена без ошибок 

 ERROR  := M1.2  //Работа завершена с ошибками 

3 

 STATUS  := MW2  //Код ошибки 
4 Сохранените OB 1 с помощью File > Save.  
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5. Шаг: описание структуры данных блоков (также обратитесь к руководству, раздел 
"Вывод текстовых сообщений на принтер") 

Опишите структуру данных блоков DB с 5 по 10 и введите начальные значения. 
 

 Замечание 

Пожалуйста, соблюдайте следующие пункты при вводе и изменении начальных 
значений в блоках данных: 
1. Введите начальные значения блоков данных в режиме Declaration view. 
2. Используйте  Data > View для перехода к Data view. 
3. Инициализируйте блоки данных с помощью  Edit > Initialize Data Block. 

 

 

Таблица 1-1 Структура блока DB 5 (указатель DB): 

Адрес Имя Тип Начальное 
значение 

Замечание 

  STRUCT   
+0.0 DB_VAR1 ARRAY[0..2]  6, 0, 4 Указатель на DB 6 со смещением 0 и длиной 4 (DB 6 = DB 

для переменной 1: "Время дня") 
*2.0  INT   
+6.0 DB_VAR2 ARRAY[0..2] 7, 0, 2 Указатель на DB 7 со смещением 0 и длиной 2 (DB 7 = DB 

для переменной 2: "1500") 
*2.0  INT   
+12.0 DB_VAR3 ARRAY[0..2] 8, 0, 1 Указатель на DB 8 со смещением 0 и длиной 1 (DB 8 = DB 

для переменной 3: "Количество конфигурируемых 
сообщений") 

*2.0  INT   
+18.0 DB_VAR4 ARRAY[0..2] 0, 0, 0 DB No. 0: Указатель интерпретируется как 

несуществующий и пропускается. Переменная 4 не 
используется. 

*2.0  INT   
+24.0 DB_String ARRAY[0..2] 10, 2, 41 Указатель на DB 10 со смещением 2 и длиной 41(DB 10 = 

DB для строкового формата); 
Задание смещения 2 необходимо, т.к. в 0 и 1 байтах 
содержится информация о длине строки. 
Длина (в этом примере 41) должна соответствовать 
количеству символов, которые вводятся как "Начальные 
значения" в формате строки (в этом примере DB 10). 

*2.0  INT   
=30.0  END_STRUCT   

Сохраните DB 5 с помощью File > Save. 
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Таблица 1-2: Структура данных DB 6 для переменной 1: 

Адрес Имя  Тип Начальное 
значение 

Примечание 

0.0  STRUCT   
+0.0 DB_VAR TIME_OF_DAY TOD#0:0:0.0 Время дня 
=4.0  END_STRUCT    

Сохраните DB 6 с помощью File > Save. 

 

Таблица 1-3: Структура данных DB 7 для переменной 2: 

Адрес Имя Тип Начальное 
значение 

Примечание 

0.0  STRUCT   
+0.0 DB_VAR INT 1500 Предел 1500 литров 
=2.0  END_STRUCT    

Сохраните DB 7 с помощью File > Save. 

 

Таблица 1-4: Структура данных DB 8 для переменной 3: 

Адрес Имя Тип Начальное 
значение 

Примечание 

0.0  STRUCT   
+0.0 DB_VAR Byte  B#16#0 0 = Номер конфигурационного сообщения (Текст 

сообщения No. 0 = "достигнут") 
=2.0  END_STRUCT    

Сохраните DB 8 с помощью File > Save. 

 

Таблица 1-5: Структура данных DB 9 для переменной  4: 

Адрес Имя Тип Начальное 
значение 

Примечание 

0.0  STRUCT   
+0.0 DB_VAR Byte  0 DB 9 для переменной 4 не используется. 
=2.0  END_STRUCT    

Сохраните DB 9 с помощью File > Save. 
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Таблица 1-6 Структура данных DB 10 для строкового формата (string): (обратитесь также к руководству, раздел 
"Преобразования и инструкции управления выводом на принтер") 

Адрес Имя Тип Начальное 
значение 

Примечание 

0.0  STRUCT   
+0.0 DB_VAR STRING[41]  'At %Z the 

value %N the 
limit of %i 
liters' 

%Z: переменная 1 в строковой переменной (время дня) 
%i: переменная 2 в строковой переменной (1500) 
%N: переменная 3 в строковой переменной (номер 
сконфигурированного сообщения) 
Введенное в строку начальное значение содержит 41 
символ (включая  пробелы).  
Следующее применяется для длины строки, указанной в 
графе Тип как "STRING": 
Количество символов в начальном значении не 
превышает 254 байт. 

=2.0  END_STRUCT    

Сохраните DB 10 с помощью File > Save. 

6. Шаг: создание таблицы переменных 
Откройте таблицу переменных VAT_1 и введите следующие адреса: 

 
 Адрес Символ Формат 

отображения 
Значение 
состояния 

Модифици-
рованное 
значение 

Примечания 

1 M 1.0  BIN  2#0 Стартовый бит (по положительному 
фронту) 

2 M 1.1  BIN    
3 M 1.2  BIN    
4 DB6.DBD0  TIME   Текущее время дня 
5 MW 2  HEX    
6 DB8.DBB0  HEX  B#16#00 Номер конфигурационного 

сообщения 

Сохраните таблицу переменных VAT_1 с помощью Table > Save. 

7. Шаг: загрузка программы 
 
Шаг Действие 
1 В SIMATIC Manager в Вашем проекте выберите папку "BLOCKS". 
2 В режиме STOP CPU загрузите блоки в CPU, используя PLC > Load. 
3 Переключите CPU в режим RUN. 
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8. Шаг: проверка программы 
 
Шаг Действие Результат 
1 Переключите таблицу переменных в режим ONLINE 

с помощью PLC > Create connection to > 
Configured CPU.> 

 

2 Активируйте режим наблюдения с помощью 
Variable > Observe. 

Вы можете наблюдать текущее время дня по 
адресу DB6.DBD0. 

3 Сформируйте положительный фронт меркера 
M 1.0, стартовый бит для FB 4, поочередно вводя 0 
и 1 как модифицируемое значение, и активируйте 
ввод, используя Variable > Modify value activate. 

При каждом положительном фронте пускового бита 
на принтер выводится следующее сообщение: В 
xx:xx:xx.xxx достигнут предел 1500 литров. 

4 Для байта DB8.DBB0 задайте значение 1 и 
активируйте, используя Variable > Modify value 
activate. 

 

5 Сформируйте положительный фронт меркера M 1.0 При каждом положительном фронте пускового бита 
на принтер выводится следующее сообщение: В 
xx:xx:xx.xxx превышен предел 1500 литров. 

6 Для байта DB8.DBB0 задайте значение 2 и 
активируйте его, используя Variable > Modify value 
activate. 

 

7 Сформируйте положительный фронт меркера M 1.0 При каждом положительном фронте пускового бита 
на принтер выводится следующее сообщение: В 
xx:xx:xx.xxx меньше,чем предел 1500 литров. 
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